Multisampling while using Bloom effect


I try to achieve a realistic architecture simulation, and to get a nice clean view multisampling is quite important for me. I wanted to add a bloom filter to increase realism, but then the antialiasing of the edges was gone.

Is it possible to restore multisampling while using post effects like bloom? I found the function setNumSamples() in FilterPostProcessor, but it seems to have no effect in my case. Tried on GeForce 7 and 8 graphic cards…

Thanks for any hints!


I tried to enable multisample for filters, but the thing is in opengl 2.0 you can’t read the depth buffer when it’s multi-sampled.

So this particular point is still on hold for now.

However bloom does not the use depth buffer, so it could work as long as you don’t have in the filter stack a Filter that uses depth (SSAO, LightScattering, Fog).

If you want to enable it all is done you just have to copy the FilterPostProcessor and change line 237 from

if (numSamples > 1 && caps.contains(Caps.FrameBufferMultisample) && caps.contains(Caps.OpenGL30)) {


if (numSamples > 1 && caps.contains(Caps.FrameBufferMultisample)) {

then set numSamples to whatever value you want.

But…be aware that if you use any of the depth using filters above, the scene will not render properly.

Thanks a lot for this explanation! I will keep the depth buffer issue in mind. For now and this case bloom is all i need.