Need to build APK for Oculus AppLab

Hey everyone:

I am trying to see if I can publish a VR app to the Oculus AppLab.
According to their site, I need to upload an APK build to their system.

I downloaded the JME SDK and used the jMonkey Initializer to create a project with desktop, android, and VR support. I can build the project and run the Desktop app.

When I run the VR desktop, it says it can’t initialize the VR environment (Which is expected since I don’t have a VR headset yet).

Looking in the project folder, I see a vrdesktop\build\distributions folder with two files:


How do I tell it to generate an APK file?

I think the jme3-vr library uses LWJGL3 OpenVR native bindings and afaik they do not support Android.

Yeah, i tried to do this and ultimately failed (not to say that it’s impossible, just that it’s hard).

OpenVR uses LWJGL bindings, so you need LWJGL. But the JME android projects don’t include that because android already exposes openGL bindings to java. (It was all a long time ago but just including both didnt work for me)

If you do get it working I would be very interested to know how.

That said. If you ask the initialiser for a VR and android project. That means a core game that runs on 2D android and a PC VR game (2 seperate launchers). It doesnt create an android-vr game (because i dont know how to do that)

Unfortunately, that means I can’t use JME3 for my application. That sucks.

Hello @NeilAgg, for android systems, there are a lot of handy APIs, of which the CardBoard VR, check it out:

The main part is creating a native head_tracker instance for your activity context, and glue your activity lifecycle to the native cardboard lifecycle, so it gets responsive, you can give it a try with a regular AndroidHarness Activity or a JmeSurfaceView Activity.

Ops, sorry, I read the question again, this might not be the right answer, I thought you were experiencing problems producing a VR application.

There are two “Android VR” repositories that I know of. Neither is maintained, but could be a start:

(disclaimer: I’m the developer)

This is a very old implementation. No support for controllers

For GVR. I don’t know much about this, but I remember there was an issue with rendering which made it not optimal, performance-wise. Whether noticable or not, I don’t know. There is some thread about it in the forum.

I don’t want to use unmaintained APIs so I am investigating a different engine.