Netbeans Latest Modules broke jMP

As you can imagine I’m pretty pissed right now. Most of jMP’s plugins are not loading, Ant, Java and IDE Platform are disabled and I can’t enable them.

Error message is ridiculous and offers no insight as to what’s happening or why except:

Activation failed: Not all requested modules can be enabled: [StandardModule:org.netbeans.modules.ide.kit jarFile: H:Program Filesjmonkeyplatformidemodulesorg-netbeans-modules-ide-kit.jar]

That's all. Nothing else. No "the X module on which this module depends on can't be loaded"... or whatever. I hate reinstalling software and I'll try to avoid that for as long as I can but this is looking bleak.

I downloaded those modules that can't load but either their builds are broken or there's something else broken elsewhere that isn't being reported.

Is there a program somewhere that can externally check those modules dependencies and spew what the cause of the problem is!?

IIRC, the latest modules were CVS, Java... and I think there was another one. Replacing Java didn't help. If I have to, I'll redownload all those damn plugins and install them manually but I'm sure there's copies strewed everywhere that will replace the new ones I'll put and/or some config issue will crop up. GAWD I hate these situations.

Any help/hint/suggestion appreciated. Thanks.

Same happened to me …

Same here… (subscribing)

You can delete the installed plugins and try reinstalling them… When theres no further dependency issues this mostly means there are none really and its just a faulty install. Otherwise I guess this will get fixed with subsequent updates. Thing is that NetBeans base is also built from svn. Cant test this myself right now tho cause I am pissed too, on the Wacken Open Air :stuck_out_tongue:

Welcome to the club @normen! :wink:

The thing is, deleting then updating will most likely bring the same problem all over again… So I’ll just download the previous day’s SVN and see how that goes.

I’ll post the solution here if I find one. :confused:

I did a complete reinstall of jMP excluding Nightly and it’s all ok… maybe is something from a recent update in Nightly what is conflicting with the other modules… but I really don’t know what I’m saying :S

You can update jMP (if the router allows you), but do NOT update the Netbean’s plugins for now. That’s what I’d do.

Thing is that the router is still broken (idk if it was reset) so the updates can always arrive with errors at the destination…

I think I’ve made some headway…

The platform now loads after having installed each netbean necessary plugins, but now all jMP’s plugins won’t load with the same message as above.

All Netbeans plugins are now enabled (although invisible) and no error cropped up or any of them are disabled.

Of course I can’t open my project with jME’s core diabled… And the router still acting up, I can’t get the latest version so I won’t delete these files. :confused:

Ok, forget that. I’m screwed.

Can’t get it to work and if I rollback to an earlier version then I won’t be able to update jMP’s own plugins.

As far as the previous post, that didn’t work either. It seems Netbeans will happily restart without its own mandatory plugins installed. They were just uninstalled. BLAH.

I will nonetheless try to tweak it into working but I’m pretty sure it’s useless.

i guess im lucky, that my stuff is still working :P, normally my stuffs the first to crack

I’ve given up.

If anyone finds a solution please post it here (short of reinstalling). Tomorrow, if there’s no solution, I’ll reinstall if the router works fine. If not then I guess I’ll have to take a break.

I’ve searched in for suspicious commits but didn’t find anything really strange. So, where else can i find other changelogs that could be related?

I’m also curious, does it happens on windows and osx? (i’m using osx)

edit: and wouldn’t be a good idea to create an issue here ?

This isn’t coming from jMP. It’s a NetBeans plugin that broke jMP, not the other way around.

I had the same problem, and I tried reinstalling JMP. Now, the problem with the plugins is solved, but JMP now doesn’t recognize some packages, so all of my projects which use jmonkeyengine are giving errors on almost everything i do.

beniboy said:
I had the same problem, and I tried reinstalling JMP. Now, the problem with the plugins is solved, but JMP now doesn't recognize some packages, so all of my projects which use jmonkeyengine are giving errors on almost everything i do.

That's normal. We can't update jMP's plugins, thus we're stuck.

And with the site also acting up... *sigh*

Thats not normal, you forgot to delete the settings which include the plugin updates. A vanilla Alpha-4 install works as it always did.

@normen there’s no way jMP can resolve Nifty 1.3 if we can’t update. Alpha has only 1.2.

After some more tests, the following updates will break jMP.

Local History




If I update to the last version of those, I’m getting a slew of error after jMP’s plugins has been updated. Here’s a screenshot of what it says:

That’s for subversion. It seems there’s some weird updating issue. It wants an earlier version than what’s installed… Incomprehensible.

That’s after reinstalling and updating those I knew wouldn’t break jMP btw.

Right now I feel like killing someone.

Got fed up with this whole ordeal and installed the latest Netbeans, downloaded the latest Nifty jars from googlecode, fixed project’s libraries with the previous and now I have a working installation. Granted I don’t have all the tools of jMP, but at least now I can work.

That’s a solution I can work with for a while, at least for the time for the issue to be fixed.