New to JME!


After about 4 months of messing around with the Irrlicht Java wrapper (jirr) which has been left in a broken neglected state for a long time - i stumbled across JME thikning this would be the thing to code my game in once and for all!

On visiting the dowload section / wiki I cannot see where or what to download to get started!

Can somebody hook me up with the correct link for the latest release of jME!

Thanks so much guys, looking forward to this, looks like a great community!


You’re coming to your first decision: JME 1.0 or JME 2.0?

JME 1.0: Stable, won’t change, older.

JME 2.0: New features, API can change easily, potential bugs, etc.

If you’re wanting instructions on Building JME, it will depend on what type of IDE you’re using. Most of the links for setup can be found in the Wiki… check here for a list of Wiki articles designed to get you started.

Glad to see another member of the community.


Wanna give us a little insight as to what you're project is, btw?

Em, well i would want to use 2.0 !

Do i just follow the same links as shown above?

I am making a 3d tower defence game.

I started a blog a while back to track development :

Sorry, I guess 2.0 isn't on that page… I know it's checked out through SVN. Check the "download' button on this website to get a link to the GoogleCode SVN.

Heh Jirr…I looked at that ages ago when I was playing around with Irrlicht, jme was really a gold mine when I found it. Before that I was looking at jumping into Java3D…glad I found the monkeys first :wink:

so if i gfind the googlecode svn, is it the same instructions as on the wiki? :roll:

Yeah I am kind of hoping this is the engine i finally settle on!


I found the svn and downloaded it all, added all jars in lib to the buildpath but when i run the the following errors occur:

11-Sep-2008 17:58:02 start
INFO: Application started.
11-Sep-2008 17:58:02 com.jme.system.PropertiesGameSettings <init>
INFO: PropertiesGameSettings created
11-Sep-2008 17:58:02 com.jme.system.PropertiesGameSettings load
WARNING: Could not load properties. Creating a new one.
11-Sep-2008 17:58:02 class jmetest.TutorialGuide.HelloWorld start()
SEVERE: Exception in game loop
java.lang.UnsatisfiedLinkError: no lwjgl in java.library.path
   at java.lang.ClassLoader.loadLibrary(Unknown Source)
   at java.lang.Runtime.loadLibrary0(Unknown Source)
   at java.lang.System.loadLibrary(Unknown Source)
   at org.lwjgl.Sys$
   at Method)
   at org.lwjgl.Sys.doLoadLibrary(
   at org.lwjgl.Sys.loadLibrary(
   at org.lwjgl.Sys.<clinit>(
   at org.lwjgl.opengl.Display.<clinit>(
   at com.jme.system.lwjgl.LWJGLPropertiesDialog$
   at jmetest.TutorialGuide.HelloWorld.main(
11-Sep-2008 17:58:02 cleanup
INFO: Cleaning up resources.
11-Sep-2008 17:58:02 com.jme.system.lwjgl.LWJGLDisplaySystem <init>
INFO: LWJGL Display System created.
11-Sep-2008 17:58:02 start
INFO: Application ending.

Any Ideas?

It's missing lwgl in the library path, when you were setting up the library stuff, did you set the "Native Library Location" under the lwgl.jar? You have to set it to your workspace's lib folder.

This is described near the bottom of the setting up in eclipse:

If you're not using eclipse, then I don't know if its different in netbeans or whatever other java IDE, as I only use eclipse.

renegadeandy said:


I found the svn and downloaded it all, added all jars in lib to the buildpath but when i run the the following errors occur:


Any Ideas?

One simple solution to avoid this is to put all your dlls in you projects working directory (This is where the folder src and bin is, but not inside these folders ).

ahh, right, got it now.

:smiley: so I can run those examples, nice.

So in JmE can i use my old models,  like the .x, .md2, .3df.etc etc etc

renegadeandy said:

I am making a 3d tower defence game.

Cool. Keep us up to date :)
renegadeandy said:

ahh, right, got it now.

:D so I can run those examples, nice.

So in JmE can i use my old models,  like the .x, .md2, .3df.etc etc etc

I don't think so with .x, but there are format converters for .md2, .md3, .obj, .3ds, milkshape,collada, ase, and something called X3D which I think is the XML format they use for the JME XML format? You can load your models up directly using these loaders, or use them to load up the model and then save it to the .jme format.

On the wiki there's a uniform model loading code snippet that may be useful if you want to streamline model loading, plus you should also check out the HelloModelLoading tutorial which gives a good example of loading an .obj model.

If you use DeleD3D, I've written a first release DXS converter which I posted in the tools section too ;).

Right, am just settling down to have a play with jME and an odd problem is happening. I am using the HelloLoadingModel example.

I have found the uniform model loader of the wiki and am using that! Looks like a great little tool to have I must admit!

I just created a  new project and added the original jme project to the build path - that an ok way of making it work?

If anybody also sounds interested in this project - please join me on my teamspeak server for the game where the team communicates! at :

Thanks so much guys!

Maybe im just being dumb, but i dont see any method on the Node object to allow me to position it in a certain place?

How does positioning of nodes on the scene graph work?!

To set the position of a node:


ahhh! Must admit thats not entirely obvious as a position setting method - of couse the docs would ahve told me that, but when i search for the word position in the Node methods list - no results?!

well translation is a common term for a position in a scene graph based engine.

Its important to understand the difference between Local and World translation.

ok so if i had an enemy node. And had attached a healthbar child node to this, i would use setlocaltranslation on the healthbar to move it to the top of the enemy node - and then use set  local translation on the enemy node to change its position in the world as that node is a child of the root one>?