Nifty + applet + close popup menu = crash. Old nifty version?


Normally during the day i run my applet through jmp. And when i do i don’t experience any problems.

However, when i deploy the applet to the server, and try to close the popup menu, the applet crashes.

Having a hunch at what the problem is, i comment out the “nifty.closePopup()” line which is the “new” way of closing popup menus (as of 1.3.1).

Then it works fine, but of course, when running it locally, my menus don’t disappear.

This leads me to the question;

What nifty version is jmp using when building applets for deployment? Looking in the .jar, it seems they’re from 110605. Is it possible to update this?



jMP uses the version that is registered with the project, it generates the code.jar from the dist/lib directory. As of the latest nightly that is the one that is included in the build of jME3 as well, so 1.3 “final”.

i use the latest nightly build and my applet works perfectly with nifty.closePopup(popup,getId());


a) looking at the librarys included to your project. if there aren’t nifty 1.3 libs you’r not running the latest version. if so update jmp to the latest nightly build.

b) turning on the java console and look out for exceptions while running the applet from the server. i don’t think closePopup is the prob but an errorcode would be more useful here.


I have no problems running the applet either, when launching it in jmp (where i have added nifty 1.3.1 to the project)

Since commenting that line out makes the problem disappear (and it also closes the menu correctly) i figure there must be some versioning.

I meant to post the dump, but i forgot to.

Well, that’s strange indeed. I will have to investigate it further.

You did “clean&build” your project I guess…? Because otherwise I’d have no idea how there could be different libraries in the Code.jar and the jMP project… oO

I checked the library paths, and they were pointing to the default (-SNAPSHOT) jars, while i’ve been using differently named ones that i got from the nifty maven repository. They must have been “reset” when i had problems updating and deleted some config stuff.

Now the question is why it’s been working locally. O_o

Anyway, hopefully it’s solved (haven’t tested yet)