No mouse when debugging in ubuntu/eclipse

Hi, I'm running Ubuntu-Linux and use eclipse to develop with jme.I have a problem with debugging applications.

I start one of the demoapplications in debugmode and setup a breakpoint in eclipse. When the breakpoint is reached, eclipse pops up and aksed me to change to the debugview. But I have no more mousepointer!?

This is somehow stolen by the running application and I cannot use the mouse to interact with Eclipse anymore. If I change to a Console window and kill the running jmonkey application I instantly get back my mouseponter in X.

Is this a normal behaviour? Is there a workaround?

Its very annoying if you can only debug things without mouse …

I have the same problem with Ubuntu and Eclipse. Try to set cursor visible.


NO, it doesn't help. In the application I can seee the mouse now, but in eclipse its not there.

try to alt-tab to another window, then alt-tab back into eclipse.

No effect! Whatever I do ( Changing task/Desktop and so on) I didn't get a mousepointer until the process is ended :frowning:

I can confirm that this problem exists. Anyone have any idea how to fix it?

It’s also a problem in the JME3 Platform… Hmm. Perhaps it’s the Java 6 Open JDK I’m using…

Have you tried pressing the Home/windows key + D? I use that and then click the IDE in the window selector. No issues so far

1 Like

TimePath, you are a legend! If you’re ever in New Zealand, let me shout you a beer.

@lancethebad: I’m a bit too young for that, but appreciate the offer :wink:

Running Alpha-4 on Ubuntu and have the same issue - once the app starts, all mouse control is lost. Home+D did nothing for me. Tried ALT-TAB, etc. but finally have to go to another machine, ssh in, and kill JMonkey. I must be doing something very basically wrong. I will try to use MouseInput.

I found that it did work as expected if I used the approach of the Example jme3test.awt.TestSafeCanvas(); when the mouse is moved out of the JM app frame, it can be used within the IDE again. Perhaps that will suggest something to the developers.

@thealy: Under the GNOME desktop environment, if you go into your keyboard shortcuts (System > Preferences > Keyboard shortcuts), there is an entry for “Hide all normal windows and set focus to the desktop”. You can change/set your shortcut there. I don’t know about KDE, or Unity, since I don’t use them

TimePath said:
Have you tried pressing the Home/windows key + D? I use that and then click the IDE in the window selector. No issues so far

Awesome! Hadn't thought of that. So simple, but you had to think of it. :)