OpenGL2/GLSL detection issue on linux

Hey there.

I’m a novice linux user running kubuntu 10.10 with an ATI HD 4730 graphics card, and I’ve run into some trouble here.

First, I will want to say that I’ve tried installing the proper graphics card drivers by going to “Additional drivers” and install the FGLRX listed there, and it didn’t quite yield expected results. When I run my game in the jmonkey SDK, it works for a few seconds, and then crashes with a “Java result” error (I think it was # 134 but i may be mixing it up with another error I’m just about to mention)

(Note: It can’t be caused by my coding, because I’ve only just switched over from windows xp, where it worked fine, and I didnt change the code since then)

Minecraft, which is a Java based (LWJGL) game, has a similar issue with my system: The menu works, but as soon as I launch the actual game, the game crashes out with an error.

After hours of research, googling and fiddling with packages, I’ve come to make sure I have the sun JDK (6) installed, and I also messed around with manually installing an ATI (or AMD) graphics card driver. The final step was disabling the FGLRX in the additional drivers section, and it’s brought me to my current state:

The previously mentioned game now works fluently with smooth fps (despite it being a really demanding game)

Which leads me to believe the manual install of the driver took over that…

But here comes the problem, when I run the jmonkey SDK, first I get told that the opengl window failed to load, and my game also quits immediately with the following error:

java.lang.UnsupportedOperationException: GLSL and OpenGL2 is required for the LWJGL renderer!

I even tried a second opengl application to make sure it worked, and it did.

My theory is that perhaps the SDK is checking for the automated installation of FGLRX and is overlooking any other secondary drivers present on the system?

I’m not sure Minecraft uses opengl2. I don’t know what other second application you tried.

It could be that your driver is still reporting that opengl2 is not supported and it’s just not required for those other apps. I don’t know, though… Linux graphics drivers are always sort of a mystery to me.

Minecraft is old school opengl no shaders or other fancy stuff there. Animatedtextures are done pixelwise on cpu (Thats why using a large texturepack reduces performance dramatically) So i guess it is not using opengl2.0

The other thing I tried was a sourceport for doom, namely skulltag. That doesn’t use opengl 2 either I guess.

Also there is an option in the SDK that lets me use opengl 1 instead of 2 and i still got the error upon restarting it. That’s partially why I thought it was weird that those games worked and the SDK didn’t.

My next idea was to try a GLSL mod for minecraft to see if it worked, turns out it didn’t. I went on and tried yet another manual install for the drivers and this time I succeeded for good. It’s kinda funny that there are tons of guides on this and most of them are different from eachother. This is the one I followed in case anyone gets similar issues:

The fact that the default drivers offered by the system didn’t work, doesn’t help my ever growing hatred towards ATI cards…

Anyway. I’m glad it’s finally working properly. Thanks

@dancso said:
doesn't help my ever growing hatred towards ATI cards...

You get numb to it after a while. My hatred has been steadily growing since my first ATI "All in Blunder" card in 1992... then I largely ignored them until the "2000s" when I started doing serious open GL work again and the support was so abysmal.

The situation has improved a LOT over the last 5 years, though. Now at least the OpenGL support is pretty good... certainly compared to the laughable state it was a few years ago.