OpenGLException: Invalid enum (1280)

can anyone shed any light on the following exception?

org.lwjgl.opengl.OpenGLException: Invalid enum (1280)
   com.jme.renderer.lwjgl.LWJGLRenderer.displayBackBuffer(Unknown Source) Source) Source)

it's from one of my users with this machine spec:

can i safely assume that the user simply does not have a good enough graphics card to run lwjgl/jme? or is there something in my code that i can do to fix this? it would be nice to be able to exit gracefully from situations like this (avoiding a crash).

Generally this means that the driver reports it supports something but then really doesn't.  A driver update usually fixes the problem.

Unless it's a Via/S3, which just plain suck driver wise.

You can tell the user to try other drivers, but don't expect too much. If you want your application to be less "crashy" you can lock out Via/S3 users, or at least give them a warning that their hardware is not properly supported.

Is this the same Problem like the Savage3 DDR pro?

this damm thing also does'nt work normaly. I coult render it with JMEApplet and deactivated lightstate.

Now it looks boring without light, but it works :expressionless:

yes it's a VIA/S3G UniChrome Pro IGP/MMX/SSE

Yes, in fact Savage is the same core as UniChrome, just an older version. (From before it was bought by Via).

Only Intel, nVidia and AMD (Ati) are really reliable. Sis is a bit flaky but people have got it to work. S3 just plain sucks for OpenGL. (well and DirectX too, but there they at least try).

in my case, this exception is not a driver issue. i just tried to use to big a texture for my card. i tried 4096x4096 and my graphics card can only do 2048x2048. i downsized the texture and it works now.

so long,

1 Like