Ortho queue is rendered under everything else

Well, I wanted that Compiz and jME were more compatible, so I switched to AIGLX instead of XGL. Everything works right. I've done all tests, but I discovered a little bug: the ortho queue is rendered under everything else, instead of on top of it.

@ MrCoder: No, I've got the latests drivers.  :smiley:

@ Anyone claiming it's compiz or XGL: I use AIGLX for the rendering (that's normal Xorg + composite extension). Compiz doesn't affect it, it's just for the fancy effects.

Geforce 7600 GS (AGP).

I'm going to test this under windows too. aargh, windows.

@ Anyone claiming it's compiz or XGL: under windows it's the same. going to try this on another comp.

On the other comp (ATI Mobitilty Radeon 7500), it's the same. (Win & Lin). You can better fix this before 1.0 :wink:

which tests are you running? (seems to work for me)

Run TestRenderQueue…  now hit M to turn on using queues…

TestRenderQueue is the one of the webstart demos (in system) ?

I pressed about any key on my keyboard. It seems like "a" did the job… sorry for making troubles for nothing  ://