Piecing together terrain using height map chunks

I’m working on piecing together a height map I put together & when importing using the sdk I get a small bug when trying to do so.

This image will help get a better understanding. (each terrain chunk is 1024x1024)

here is the first tile image (no errors on this)

& the tile that isn’t working (Note loading it to it’s own scene does the same thing)

Can anyone spot whats going on here? & is this even a good way to do things?

What I’m trying to accomplish is tiling 10 of these to make a rather large world. When I’m done I’ll split them into separate scene’s. & This error is exactly why I started this way.

It appears that, at the end of the images, is a black line that is causing that bug. Maybe is because of the image editor you are using? Try using another editor. By the way, you can also use the built-in terrain creator of the SDK if you want.

Doesn’t seem to be the problem. & That’s what I thought at first. I’ve tried gimp, mspaint, photoshop, etc… I still have the same problem.

“I’m working on piecing together a height map” - That tells us close to nothing. Putting the images together, or using TerrainGrid, or using your own “chunk”-objects, or trying to place TerrainQuads in the SDK editor, or…?

I gave 2 images 16,26 & 15,26. Those are just 2 chunks from a 16x26 map. I’ve done this before just importing the pictures above. By piecing together I mean I took my original map (13312x8192) & split it into 1024x1024 chunks to use on a 1024x1024 map using the sdks create terrain. I’ve done it before with large worlds in the past but for some reason it’s not linking this height map? & I’ve tried opening the images on another system using various image editing software’s & there is no black line that appears.

And so your images properly overlap at the edges by one pixel?

No. Just adding another line (1025x1025) instead of 1024x1024 would fix this?

Remember, the ‘texels’ of the height map are defining the corners of the terrain quads. So you get a quad between 0 and 1, between 1 and 2, and so on… all the way up to between 1022 and 1023 where it stops. (1024x1024 means 0 to 1023)

…so what do you suppose happens between 1023 and the 0 of the next tile?

1 Like

Does what it was doing. Thank you sir for your help. I did this before I switched back to 2D & will have to pay attention to what I’m doing a bit more during this re-transition.