Problem importing Ogre models

Hey guys, new to this board, I just want to thank first the jMonkey dev team for the work. Cheers guys !

My main problem now comes when I use the importer for Ogre models, I got a silly error just like I’m trying to import a file that has no recognized filetype (just like I’m trying to import a .3ds or stuff like that).

When I :

this.attachChildAt(this.assetManager.loadModel("Models/Sinbad/Sinbad.mesh.xml"), 0);

I get :
Grave: Uncaught exception thrown in Thread[LWJGL Renderer Thread,5,main]
java.lang.IllegalStateException: No loader registered for type "mesh.xml"

Any ideas ? That's a strange stuff, everything worked well yesterday, just before I updated my SDK !


EDIT : I forgot to add : when I load an obj (ie, "Models/Teapot/Teapot.obj" ), everything works fine.

Okay, I tried on my laptop and after some clean+restart, the Ogre .mesh.xml import worked. The SDK on my laptop is up to date as well, so there should be the same error… But it is working.

My guess is that my project is hosted on my Dropbox, and the Dropbox folder differs from different computers, you know. Tht may cause the librairies or assets not loaded in the same way, I don’t know. I think I’ll look into that later when I come home.

do you use the sdk or a own ide?

If second are all plugins correctly in the classpath?

On start are there any errors about something not found?

I use the SDK, not an IDE. No errors on start. I came back to home and everything works now. I didn’t do anything. I think the clean on my laptop solved it. Maybe an issue related to Dropbox. Thank you EmpirePhoenix

My problem with this error message was that I forgot to include jME3-plugins.jar in my dependencies (working from Eclipse).