Problem using Blender models

Hello all,
I’m having a pretty rookie question as to why my models from Blender are not being correctly exported/imported. I have installed the Blender Ogre XML via the JME3 [tools > ogreXML > install Blender OgreXML] in its correct location as it does appear in my Blender addons and I am allowed to export using the OgreXML export. The problem I am having is that no matter how I import into JME3 it is not adding the textures/materials to the model, it will simply import the mesh leaving me with a grey uncolored model to work with. I have tried to copy/paste folder into models and the import via the import button on JME3. Here is what the model looks like through the import button ( it looks the same in scene composer as well).

This is the model I’ve been trying to use. I have tried several models to help eliminate the fact something could be wrong with them.

Here is what is exported once I run the Blender Ogre export.

Please help I would very much appreciate it. I’m a decent programmer but a terrible artist and I really dislike messing around with Blender. I literally have almost no experience with Blender so any small steps would be appreciated. Let me know if anymore additional information is needed.

Sorry for a mistake, the model I am using is at this URL

And the images are clickable, not sure if there are supposed to be black ‘x’ or not. Thank you