Problem with J3o conversion from mesh.xml

Hey guys! I have been trying for very long to convert the .3ds to .mesh.xml and then to import it into the JME3 platform to use.

Firstly, I exported the .mesh format from 3DSMAX. (which creates a .mesh and .materials)

Then I used the CLI tools of the OrgeXmlConverter and OrgeUpgrader to change the .mesh to .mesh.xml

Finally, I imported the .mesh.xml from step 2 and .material from step 1 and all the texture images into the project folder.

Heres the problem: I cannot convert the .mesh.xml to a j3o and I cannot open the .mesh.xml in the scene editor as well. This is the error I get when converting it to J3o:


at com.jme3.export.binary.BinaryImporter.readObject(

at com.jme3.export.binary.BinaryImporter.load(

at com.jme3.export.binary.BinaryImporter.load(

at com.jme3.export.binary.BinaryImporter.load(

at com.jme3.asset.DesktopAssetManager.loadAsset(

at com.jme3.asset.DesktopAssetManager.loadModel(

[catch] at com.jme3.gde.core.assets.SpatialAssetDataObject.loadAsset(

at com.jme3.gde.scenecomposer.OpenSceneComposer$


Can someone pls help me! I have tried for so long to get this working that it ain’t funny anymore :confused: thanks ppl! :slight_smile:

The file has to be in the assets folder for conversion, or use the Model Import Tool (green button). Also, update to beta if you didn’t do so yet, you might also be able to load the 3ds file in blender and save it as a .blend file if the ogre solution won’t work.

Normen: Thanks for the quick response :slight_smile: I have tried that but the textures do not appear when I import it to blend :confused:

Ok, Thanks Normen! I did the import model from Blend and it works! haha, appratenly the orgexml cli tools are kind of deprecated… Thanks so much!

Yeah, the best way to import formats that jME3 doesn’t support is by using Blender and exporting to mesh.xml or loading the file directly