Problem with MonkeyZone! help me please :)

Hi there

I have a big problem with your MonkeyZone project.

I following your steps in the MonkeyZone page, but my platform (JMonkeyPlatform 3) I have some error.

One of this is :



server.broadcast(new ChatMessage(”Server”, nam left the game”)); the error is -> ”no suitable method found for broadcast(com.jme3.monkeyzone.StartGameMess method com.jme3.network.Server.broadcast(com.jme3.ne com.jme3.network.Mesage) is not applicable ( act and formal argument lists differ in length) ….”

Now I ask me , if is this a problem with my libraries?

Where can I download update library for this monkeyzone?



Thank you!

I wait your answer.

First of all, did you update to the nightly build of jMP? I opened this project this week and I don’t remember running into that much errors that were hard to track down. Secondly, perhaps I should commit the small changes I made to make sure other people can run MZ right away. @normen, I’ll send you my google acount name :stuck_out_tongue:



Oh by the way, is that error crashing the game and of any influence or just something that pops by and makes no point anyway?

I don’t know How to update nightly build of JMP! :frowning:

Could you to send me the steps for update it?



thank’s baalgarnaal! :wink:

Open JMP.

Press F1

Read the help on how to update to nightlies.

Ok, I found it!

Now, it is showing me this message, when I try to update:



Some plugins require plugin Classpath APIs to be installed.

The plugin Classpath APIs is requested in version >= 1.30 but only 1.29 was found. The following plugin is affected: AssetPack Support

Some plugins require plugin Explorer & Property Sheet API to be installed.

The plugin Explorer & Property Sheet API is requested in version >= 6.37 but only 6.35 was found. The following plugin is affected: Terrain Editor



What I must do for update " plugin Classpath APIs" and “plugin Explorer & Property Sheet API”?

Or can I update it without to think at this things?

thank’s a lot! :wink:

okok

I done it!

When I run it, it show me an exception that it’s not found the jme3tools.navmesh.NavMesh class.

I checked in the folder where should is this class, but there is not! :frowning:

Where can I try it?

Ok Guys!

Now , it give me another error :frowning:

It running, but the screen disappears when I must insert my nickname, and I don’t know How to do.



This is the error:



GRAVE: Uncaught exception thrown in Thread[LWJGL Renderer Thread,5,main]

java.lang.NoSuchMethodError: de.lessvoid.nifty.NiftyInputConsumer.processMouseEvent(IIIIZ)Z

at com.jme3.niftygui.InputSystemJme.onMouseMotionEventQueued(InputSystemJme.java:106)

at com.jme3.niftygui.InputSystemJme.forwardEvents(InputSystemJme.java:169)

at de.lessvoid.nifty.Nifty.update(Nifty.java:224)

at com.jme3.niftygui.InputSystemJme.endInput(InputSystemJme.java:94)

at com.jme3.input.InputManager.processQueue(InputManager.java:773)

at com.jme3.input.InputManager.update(InputManager.java:837)

at com.jme3.app.Application.update(Application.java:567)

at com.jme3.app.SimpleApplication.update(SimpleApplication.java:235)

at com.jme3.system.lwjgl.LwjglAbstractDisplay.runLoop(LwjglAbstractDisplay.java:144)

at com.jme3.system.lwjgl.LwjglDisplay.runLoop(LwjglDisplay.java:185)

at com.jme3.system.lwjgl.LwjglAbstractDisplay.run(LwjglAbstractDisplay.java:218)

at java.lang.Thread.run(Thread.java:662)



thank’s again guys :wink:

Hmmm seeing you fix your own problems in approximately 30 mins so far I think you should be close to solving it yourself at this point :stuck_out_tongue:

Anyway, could you open you libraries list and see if it contains 3 jme3libraries - nifty-xyz in there? I remember I had to add those myself since an update for some reason, although I’d expect that would give an error during compilation (sooo, clean and build may be needed at this point)

I opened my libraries list , but I don’t found this “nifty-xyz” library.

What is this “nifty-xyz” library?

I have some nifty libraries, but I don’t know if are those.







I hope I will solve it!!! :slight_smile:

baalgarnaal I have tried the problem.

It’s running but if I move the mouse the application goes in creash! :frowning:

Why?



It’s a strange thing!!

lelloarm said:
I opened my libraries list , but I don't found this "nifty-xyz" library.
What is this "nifty-xyz" library?


./facepalm.
Xyz is just a random filler I put here so you can recognize the libs I refer to. Could you tell me what nifty libs those are? Exact names?
I can only gess your libs are wrong at this point. If the error persists perhaps we should wait for an answer from the maker of nifty. Oh and try the clena and build button just to be sure, you know, that icon with the hammer and a broom.

I did as you say me ( hammer and broom) but the result is not changed.

My nifty-xyz libraries are:



nifty-1.3-SNAPSHOT

nifty-default-controls-1.3-SNAPSHOT

nifty-examples-1.3-SNAPSHOT

nifty-style-black-1.3-SNAPSHOT

nifty-style-grey-1.0



I need other libraries?