Problems building JME

I attempted to build JME using the getting started instructions, though I ran into a complication. Namely:

[javac] /home/nolan/src/cvs/jme/src/com/jme/sound/fmod/ package org.lwjgl.fmod3 does not exist

[javac] import org.lwjgl.fmod3.FMOD;

[javac] ^

. . .

I first checked the install instructions, which state that the lwjgl sources are included, but they didn’t seem to be in this instance. I then hit and downloaded the latest jar, added it to my CLASSPATH and the problem was fixed.

Even though it worked, I’m wondering if I skipped a step somewhere?

Also, I’m rather new to Java development and ant. Out of curiosity, why did I have to add lwjgl_fmod3.jar to my CLASSPATH, yet there were other jars in the lib directory that I didn’t need to add? Again, am I missing a step somewhere? :slight_smile:


go to, download their product, unzip, navigate to the libs folder, copy/paste the lwjgl-fmod3.jar and lwjgl-fmod3.dll into the jme libs folder.

Now, go to and download fmod, extract the dll to the jme libs folder, and everything should now work…


I have updated the missing libs

looks like version 1.9 of the build.xml does not have the library lwjgl_fmod3.jar in the classpath for the compile target.

revision 1.9 reads:

<javac source="1.4" srcdir="${src}/com" destdir="${class}" classpath="${seg}/lib/lwjgl.jar:${seg}/lib/jogg-0.0.5.jar:${seg}/lib/jorbis-0.0.12.jar" listfiles="no"/>

should read:

<javac source="1.4" srcdir="${src}/com" destdir="${class}" classpath="${seg}/lib/lwjgl.jar:${seg}/lib/jogg-0.0.5.jar:${seg}/lib/jorbis-0.0.12.jar:${seg}/lib/lwjgl_fmod3.jar" listfiles="no"/>