Problems getting jme2 started on vista64


beeing new to jme i just tried to get it started following this tutorial (

until the point "Build jME 2.x into JARs:" everything works fine. then i got the same problem as posted here (

there is no build.xml in the eclipse project explorer. ok, so i imported build.xml and build-import.xml. now it occures that ${libs} can't be found just like here (, but i don't know how to fix it and i'm wondering why build.xml is missing int he project explorer at all.

thanks for the help in advance.

ok, got it work now.  followed the video tutorial ( this way of installing worked fine for me.

a video says more then 1000 words :slight_smile:

I’m trying to go through that same video tutorial but when I go to check out jme2 from I get a error message that says:

Error validating location: “Unable to load default SVN Client”

Keep location anyway? Yes or No

Doesn’t matter what I choose it just creates the SVN repository location but then it doesn’t contain anything.

Any help would be greatly appreciated :slight_smile:

I’m using Eclipse 3.5 on Vista 64 bit like the original poster.

"Unable to load default SVN Client"

never had that error yet, but it seems common when googling for it.

Seems to be a subversion version problem :)

Interesting…I used a previous version of Subclipse ( and it worked fine. I also uninstalled TortoiseSVN but I don’t know if that was causing any of the conflict.

So if anyone else runs into the problem of getting a error message that says “Unable to load default SVN client” try using a previous version of Subclipse instead.


Now I’m having trouble running the JME tests. When I try to run them I get an error that says:

java.lang.UnsatisfiedLinkError: C:UsersJackDocumentsGame Workspacejmeliblwjglnativewindowslwjgl.dll: Can’t load IA 32-bit .dll on a AMD 64-bit platform

However under the path: Game Workspacejmeliblwjglnativewindows there is also a lwjgl64.dll which I’m assuming is to be used for an AMD 64-bit platform. Anyone know how to get LWJGL to look at this file instead of the default lwjgl.dll in Eclipse 3.5?

[UDPATE]: Hopefully this will solve my problem…didn’t search well enough. I apologize :frowning:



Ok now something very odd happened. I tried running in debug mode to see if I could find anything more to help me solve my problem, but the test worked perfectly! However, running it as usual still gives me that error.

I suppose one solution is to just go back to using 32-bit VM, Java, and Eclipse and wait for 64-bit to have the bugs worked out a little more. It's just frustrating :frowning:

I found that apparently even though the lwjgl64.dll file is there Windows is still trying to load the lwjgl.dll file and then when that fails (as it should) the program just dies instead of looking for the lwjgl64.dll file to load instead.

I just don't understand why it even has to look for the default lwjgl.dll file in the first place. Why can't it default to finding the lwjgl64.dll file?

From the LWJGL forums it looks like the devs are still ironing out the 'kinks' in their 64-bit implementation so maybe I should just go back to 32-bit at least for a while :slight_smile:

Oh well if anyone hears anything different or gets it working correctly let me know. I'll keep researching it to see if I can get it to work. I'm not quite ready to give up and go back to 32-bit quite yet!  :wink:

JackKnifeZero said:

So if anyone else runs into the problem of getting a error message that says "Unable to load default SVN client" try using a previous version of Subclipse instead.


I've gone through this quite a bit on Linux.  It means that the subclipse instance is having trouble interfacing with an svn client.  On linux, you have to interface with a native svn client.  On windows, it seems that there is a java implementation of the client available.  Double check that you have the SVNKit Client Adapter and SVNKit Library installed.  This should give you access to the java implemented svn client.