Problems installing JME on Eclipse

When trying to install JME on Eclipse, I'm using

to do so.

During step 9, I get an error

An out of memory accured. Consult the "Running Eclipse" of the readme file....
See the .log file for more details.

This happens at 'Building workspace'

I tried to change -Xmx to a higher value to no avail.

Am I doing something wrong? And if so, what?

It does work if I just download and use the nightly build.

Did you "Consult the "Running Eclipse" of the readme file…"?  (I'm not an eclipse user but you need to raise the memory that's available for eclipse)

First, which version of Eclipse are you using? Different versions require different flags for passing the -Xmx argument to the VM.

For instance, in Eclipse 3.1, you would have to execute

eclipse -vmargs -Xmx512m

while on Eclipse 3.3 (Europa) the eclipse executable does it autometically…

Oh, and don't forget to read the README file Irrisor and Eclipse told you to…  :wink:

I am using Eclipse 3.2 on ubuntu. There is an eclipse.ini file to set Xmx (/usr/lib/eclipse/eclipse.ini). It didn't seem to work for me.

eclipse -vmargs -Xmx512m

worked fine.

Thanks alot!  XD

As I said, It works, but when I try to add the jars from jME/target/ , that directory is empty!

I can add the jME project to my project as in

right-click your project → Properties → Projects tab → Add.. → check jME → OK → OK.

Wait a sec! Have you check out from CVS? If so, you can just find the JARs in jME/lib/ and not in jME/target/ which would be if you used the Ant script directly to build the JARs.

OK to begin with, I am a Newbie in eclipse and JME.

I did check out from CVS.

The tutorial at

gives two options on how to use jME in a project.
The second one (adding jME-project to build path) works.
The first one (using the jME-jars) doesn't work.
I was first looking for the jars in jME/target/. Now I know they are in jME/lib/.

To add the jME JARs to your projects build path, right-click your project → Properties → Java Build Path → Libraries tab → Add Library... → User Library → User Libraries → New, enter jME for the User library name. Select jME → Add JARs..., browse to the folder jME/target/, and select all the JAR files and press Open. Then Add Library... → User Library → jME required2) → OK → OK → Finish.

It is not a very big problem, I can live with that. :wink:

It is just that I must be doing something terribly stupid.

Yes, it is unfortunate that the articles in the Wiki are not kept up to date… But this is a great community (don't let me fool you into thinking otherwise  ;)) Also, if you want to correct the wiki, you can do that yourself now that you know the answer, and thus help the next generation of newbies  :smiley:

Don't worry, one of the reasons I took a look at jME is because I heard rumours of the great community.

And, oh yes good idea to let me work on the wiki  :-o

Maybe, when i know 'a bit' more of jME,

when I know a bit more english (dutch is my native), game programming,…  :oops:

One of these days… perhaps…  XD