Problems starting JME

Hi guys. I have been working with my friend to get JME to begin working on his computer.

We were doing this over the phone. Tommorow I am going to go over to his house to try to get this to work in person, but I just thought I would ask if you guys could give me any pointers of possible solutions to the problems we are experiencing.

He installed the latest version of the JDK and of galileo eclipse.

Basically we SVN checkouted the code from

In eclipse we made this code into a new project, and begin to fix the build path problems.

We made SWT_Required library with the appropriate windows swt.jar file and attached it to the build path. Then we went into the lwjgl.jar file and attached its native directory to its windows folder.

I have gotten JME to work on 2 seperate computers using these steps but for some reason this didnt work on his computer and he still got errors (over 11,000 of them! lol)

So, for a final run through before we called it a night, we deleted all of the jar files out of the build path and put them back in (taking special care to make sure we got them all) with the same results… lots of errors.

When he tried to run a jmetest class, this is the types of error he would get

Exception in thread "main" java.lang.Error: Unresolved compilation problem:
   Cannot make a static reference to the non-static field ConfigShowMode

   at jmetest.terrain.TestFluidSimHeightmap.main(

So, if anyone can give me any ideas of problems we could be overlooking I would appreciate it.


Last night I went over to my friends house to try to fix this.

I verified in person that the build paths were set correctly.

We tried using different eclipse versions.

We tried using the java off of my computer.

We tried using 2.01 stable but that didnt work either.

We ran a hello world java class to make sure that java was running on his computer and it is.

Can anyone give me any ideas as to why JME is not working on his comp?

If you need his system specs I can get them.

Nice…strange really strange! And this "static->non-static"-error is showing up on every test?

Maybe you should try to use another jdk. What version are you/the other guy using? Actually

that error makes no sense for me…

here are some of the specs from his computer

pentium 4 processor 2.8 ghz

windows xp professional sp3

512 mb DDR ram

ati radeon 2400 HD

JME versions tried: 2.01 stable and the SVN download from googlecode.

eclipse: galileo

JDK: 1.6

this seems to be a problem with JME but we cannot isolate it, later today we can post more about these errors he gets, would they help in isolating this problem?

Actually I really don't think that this is a jME problem! As yourself say it is

working at your computer! It is working at my computer and at the others' computer!

So…I think the problem is his computer / os, whatever…

Well,…that is my oppinon (don't know what the others think about it)

Hey guys, I'm the one with the problem computer :oops:

This is the error I get when I try to compile one of the test codes:

Exception in thread "main" java.lang.Error: Unresolved compilation problem:
   Cannot make a static reference to the non-static field ConfigShowMode

   at jmetest.terrain.TestTerrainTrees.main(

There are also errors in the code, notably:

Most Common errors:

X if source level is 1.5 (fixed, changed level from 1.4 to 1.6 in project settings)
cannot make static reference to non-static field X
X cannot be resolved

X refers to the specific problem.

I'm at a loss here. I've done everything I'm supposed to do in many different ways to get this working. What's going on?

What version of the JDK are you using? You need at least JDK 5.x