Problems when changing version of the JDK

I am using jME v3.24, and I have been using Java SE 1.8, but when I try to change that to a newer version of the JDK, the SDK doesn’t seem to work. It launches fine, but nothing happens when I try to open the projects window or open any tabs.

I do not believe that the SDK supports anything but JDK 1.8.
But perhaps @Darkchaos would know better?

1 Like

JVM is bundled with SDK. so any java should work. so its odd.

its only 3.3 SDK that require higher java, because netbeans itself require it.

jME 3.2.x SDKs are based on Netbeans 8. And it only goes as high as Java 8. You can get the SDK 3.3 which is based on Netbeans 11.2. It should enable you to use anything up to Java 13. The bundled Java with SDK 3.3 is Java 11.

The next SDK release will most likely let you use up to Java 14. As the master is currently on Netbeans 11.3.