Proxy server error when updating?

So i have 23 or so updates that i need to install to get jMonkey up to par but every time i try to apply them, it gets through 23% percent i get the following pop-up error:



“Networking problem in http://jmonkeyengine.com/updates/stable/3.0beta/plugins/jmonkeyplatform/com-jme3-gde-project-testdata.nbm



Check your proxy settings or try again later. The server may be unavailable at the moment.



You may also want to make sure that your firewall is not blocking network traffic.



Your cache may be out of date. Please click Reload Catalog to refresh content.”



Anyone got a fix or something obvious that i just overlooked?



Thanks.

Hi buddie



Seems to me the problem is just project-testdata. Try go to tools>>plugins in tab updates and unmark Project Test Data to update then select the plugins to update and do it. Everything will run alright.

Disable your firewall -> update -> and enable your firewall.

Its the biggest file in theupdates, I guess your internet connection is just wonky.