Runtime Crash when forceOculus=true

Hey guys,

I’m trying to set up a very simple OculusVR Application extended from the basic game example provided by jme.

To do that I have followed some old instructions from Google Code Wiki and the old Support Topic from this hub. I’m using the JAR files from the jmonkeyengine-oculus-rift project.

I also have read that, to make tests I could set the last parameter (forceOculus) to true. However, whenever I change that to true, the animation crashes as soon as I press the “Continue” button on jme GUI.

Here is my code:

public class Main extends OVRApplication {
        public static Main myApp;
        
    public static void main(String[] args) {
        myApp= new Main();
        myApp.preconfigureOVRApp(false, false, false, true); //<<<<<<The Problem
        myApp.start();
    }

And here is the error log I get from the crash:

Am I using old files or something? Is there some place I can get the latest version of them?
Any info you can provide me is going to be extremely helpful!

Hi.

It looks like you’re using the legacy project from google code?
I recommend you switch to https://github.com/phr00t/jMonkeyVR
This is the most feature-rich VR-project for jMonkeyEngine right now. It’s designed for OpenVR but works with Oculus Rift as well.

2 Likes

Hey,
Thanks for that @rickard, should help a lot.

Also, any place where I can find a proper guide on how to install phr00t’s version of jME?
I’m pretty new to this and I’m facing some difficulties…

UPDATE:
I tried to add the new ‘.jar’ files to the libraries path into my project, however it returns a version error when I run the program…

Are you using Java 8+? What is the exact version error you get?

I solved the problems. Tried to follow some of the tips given above.
Thanks for the help!