Scene content removed - How can I rescue my scene?

Hello monkeys,
I suddenly got some problems with physics again and now my scene content is removed (had this issue once and thought I solved it).

When I try to open my scene I can see the scene graph but I get the following popup message (no visual of scene itself):

So my scene seems to be totally broken.

There also is a error message, but I guess it is because of that exception, so it might not be that important.

java.lang.NullPointerException: The obj parameter cannot be null
at org.openide.util.Parameters.notNull(
at org.openide.nodes.Children$Dupl.updateListAndMap(
at org.openide.nodes.Children$Dupl.updateList(
at org.openide.nodes.Children$Keys.setKeys(
at com.jme3.gde.core.sceneexplorer.nodes.JmeSpatialChildren.addNotify(
at org.openide.nodes.Children.callAddNotify(
at org.openide.nodes.EntrySupportDefault.getArray(
at org.openide.nodes.EntrySupportDefault.getNodes(
at org.openide.nodes.Children.getNodes(
at com.jme3.gde.scenecomposer.SceneComposerToolController.getNodes(
at com.jme3.gde.scenecomposer.SceneComposerToolController.getNodes(
at com.jme3.gde.scenecomposer.SceneComposerToolController.addMarkers(
at com.jme3.gde.scenecomposer.SceneComposerToolController.refreshNonSpatialMarkers(
at com.jme3.gde.scenecomposer.SceneComposerTopComponent.sceneOpened(
at com.jme3.gde.core.scene.SceneApplication.notifyOpen(
at com.jme3.gde.core.scene.SceneApplication.access$1200(
at com.jme3.gde.core.scene.SceneApplication$
at java.awt.event.InvocationEvent.dispatch(
at java.awt.EventQueue.dispatchEventImpl(
at java.awt.EventQueue.access$500(
at java.awt.EventQueue$
at java.awt.EventQueue$
at Method)
at java.awt.EventQueue.dispatchEvent(
at org.netbeans.core.TimableEventQueue.dispatchEvent(
at java.awt.EventDispatchThread.pumpOneEventForFilters(
at java.awt.EventDispatchThread.pumpEventsForFilter(
at java.awt.EventDispatchThread.pumpEventsForHierarchy(
at java.awt.EventDispatchThread.pumpEvents(
at java.awt.EventDispatchThread.pumpEvents(

So my question now is how can I “rescue” my scene? I mean, I am a little bit frustrated of this because I worked on the scene for days and now it’s just unusable anymore. :disappointed_relieved:

Ah, I said it had to be something with physics. I can confirm that because the scene had a model which has a physic control applied. The model was linked, so I opened the original file and the whole platform crashed, but only on this model. Others worked fine (don’t know why). Anyway, it seems like this problem manipulated the scene file and now it’s kind of damaged.

Greetings, Domenic

Just moving the linked file somewhere else for now should do.

Oh yeah, forgot to mention, I already removed the linked file from the scene graph, but it does still not work!

Okay I removed some more models and now it does work again. I will have a look which spatial made my problem and will tell you then.

Do you have some Animated Models inside?
And do you probably run something less than 3.1-beta1?

If yes any animated model might kill your scene given you run an SDK between 3.1-alpha1 and 3.1-beta1

No, I don’t

No, I am using 3.1-beta1_xbuf-SNAPSHOT

Okay, didn’t know that.

Ah I didn’t look close enough at the exception. It looks really strange… Maybe I can have a look this evening.

I fortunatly made a backup where I haven’t deleted that many models. So the problem still existed but then …


While I was trying to find the sinner in my scene I found a node, clicked on it and noticed a small popup in the right bottom corner with null (pointer exception). Clicking on other nodes didn’t gave me that popup. So I decided to delete that node, closed and reopened the scene and, yeah, well, it does work again. I am not sure what kind of node this was but … it probably was my fault somewhere.

I am not sure anymore if that really came from physics. What I can say is that I added the physic control to that one model (was NOT the node I deleted btw) and when I tried to open it again (in SDK as well in the application itself), jmonkeyplatorm crashed. Then my scene was “damaged”. But I think that is another topic/issue.

Anyway, I am glad it works now and if I find additional information I will keep you up-to-date !


You aren’t running beta1, though, see:

Where it should be sdk/ at master · jMonkeyEngine/sdk · GitHub

Still a very wierd exception. Do you still have the j3o? One might need to breakpoint-step through createKeys and see where there is a faulty key

Really??? I downloaded the latest SDK, so the beta1 should be implemented, shouldn’t it?

Sorry dude, but I have no idea what you are talking about here :sweat_smile:
I never came across “keys” or something like that.