Scene editor cannot open my j3o file

I also have a GLB scene file. I convert it into a j3o format file through code. The converted j3o file can be loaded and displayed normally through assetmanager.loadmodel (“scene / hdmap”) But scenecomposer in jmonkeyengine SDK 3.0 can’t open and edit it. Does anyone know how this happened?

1 Like


firstly, SDK 3.0 is very old. You should upgrade to the latest 3.4 release.

Second, if the problem persists with the newer version. Please create issue to Issues · jMonkeyEngine/sdk · GitHub in more detail. Attach all possible screenshots and errors (stack traces!). Steps to reproduce as clearly as you can.

1 Like

Hi @tonihele ,
I downloaded the new version of the SDK 3.4 and I also confirm the same problem. I have deleted the jmonkeyplatform directories as suggested in the release notes. There are no errors or message dialogs. Simply double clicking on the .j3o file does nothing.


I also tried to create a new .j3o file with the ‘Empty jME3 scene …’ menu. Same problem, the file does not open.

Alright, so it is a Gradle project. I think it is this bug then: File is not part of a jME project but tries to find original model · Issue #379 · jMonkeyEngine/sdk · GitHub

It’ll be fixed on the next SDK release. Hopefully.

Meanwhile… A workaround could be to use the Ant project template to fiddle around with the Scene editor. Very clumsy but could work…?

1 Like

Ok, hopefully solved soon :wink:

However even with the new version of the SDK, it happens that the editor suddenly closes after a few minutes every time I open j3o files with the editor. What is it caused by?

Here a fragment of the hs_err_pidxxxx.log file

# A fatal error has been detected by the Java Runtime Environment:
#  EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x00007ffd0ba18ac4, pid=12744, tid=17796
# JRE version: Java(TM) SE Runtime Environment (11.0.6+8) (build 11.0.6+8-LTS)
# Java VM: Java HotSpot(TM) 64-Bit Server VM (11.0.6+8-LTS, mixed mode, tiered, compressed oops, g1 gc, windows-amd64)
# Problematic frame:
# C  [ig9icd64.dll+0xe8ac4]
# No core dump will be written. Minidumps are not enabled by default on client versions of Windows
# If you would like to submit a bug report, please visit:
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.

---------------  T H R E A D  ---------------

Current thread (0x00000297163b7800):  JavaThread "jME3 Main" [_thread_in_native, id=17796, stack(0x000000c5efb00000,0x000000c5efc00000)]

Stack: [0x000000c5efb00000,0x000000c5efc00000],  sp=0x000000c5efbfe880,  free space=1018k
Native frames: (J=compiled Java code, j=interpreted, Vv=VM code, C=native code)
C  [ig9icd64.dll+0xe8ac4]

Java frames: (J=compiled Java code, j=interpreted, Vv=VM code)
J 14199  org.lwjgl.opengl.GL11.nglClear(IJ)V (0 bytes) @ 0x000002970835d994 [0x000002970835d940+0x0000000000000054]
J 39164 c2 com.jme3.renderer.RenderManager.renderViewPort(Lcom/jme3/renderer/ViewPort;F)V (620 bytes) @ 0x00000297099443a0 [0x0000029709942ae0+0x00000000000018c0]
J 25549 c2 com.jme3.renderer.RenderManager.render(FZ)V (229 bytes) @ 0x000002970882d794 [0x000002970882d380+0x0000000000000414]
J 40005 c1 com.jme3.gde.core.scene.SceneApplication.update()V (317 bytes) @ 0x0000029704abcff4 [0x0000029704abac20+0x00000000000023d4]
J 39346 c2 com.jme3.system.lwjgl.LwjglOffscreenBuffer.runLoop()V (151 bytes) @ 0x000002970998ac10 [0x000002970998aa60+0x00000000000001b0]
j java.base@11.0.6
v  ~StubRoutines::call_stub

We are aiming 3.5 SDK release near end of October. That should be set in stone in a way. Whatever is ready at that time will be included, and what is not ready… will… not… be included :slight_smile: It is that simple. And this fix is already in.

For the crash… Damn… LWJGL seems to crash. I don’t have a clue :frowning:

ig9icd64.dll is the Intel Integrated Graphics driver. EXCEPTION_ACCESS_VIOLATION means the process tried to access a memory address belonging to another process and was blocked by the O/S.

You could try checking / updating your graphics drivers / trying a newer JDK11 / JDK11 from a different vendor (I like Corretto myself… I’ve had similar issues with AdoptJDK11 on Linux not playing nice with OpenGL applications… ).

But I suspect the problem may be LWJGL2, which the SDK is still using. On Linux, I can’t get a Scene editor to open at all on modern Linux distros/kernals, and I have a similar problem with Windows where the SDK bombs out every so often.

lwjgl says “driver please clear the viewport”.
driver says “Nah, I don’t feel like it.”

…driver issue. Intel drivers are known for constant issues and finding the driver version that works is a popular game.