Screen blanking

hi all

i am currently experiencing a problem i thought id solved, and have searched the forums to see if i could find a solution, but to no avail

when running any of the jmetest programs, or any of my own creation, im getting the problem of a blank screen with background color only. For example, if i run, after a random time (usually 2-4 seconds) the screen goes blank, including the fps and vertice counters at the bottom of the screen.

I previously solved this problem by running 16 bit color and increasing the res to my screens native 1024x768, and this seemed to cure the problem. but not its reoccured, and the settings havent changed from when it last worked fine.

does anyone have a definitive way of how to solve this please?

thanks for any help!

Well, the usual advice would be: update your drivers.

i already had the most recent drivers, but just to make sure im redownloading the latest offering from nvidia.

the problem is that using the same driver, it was working previously after i changed the display params, but now has suddenly stopped working correctly.

do you think this is because of the drivers, because of background programs (virus protection etc) or something unrelated to those two?

thank you

It's a very unusual problem. I wouldn't know what's causing this… it could be some quirky software, but I wouldn't rule out faulty hardware (just because it's so weird). Do other 3D applications work well on your system? Particulary the OpenGL ones.

i was speaking to a java programmer friend, he says he isnt sure if my card supports ogl, but he said most cards tend to. its a nvidia geforce fx 5500. i havent had the opportunity to test many other open gl programs, as i dont know where to find them! but im guessing my card does support ogl, as it used to work previously, which makes this problem all the more frustrating!

mtm :)

Sure… I even used jME on a nVida TNT2, a card from before GeForce even existed. You should have no problem running jME on this card. That's why your problem is so strange.

right it was a driver problem. reinstalling the driver seemed to do the trick :) thank you llama. very strange problem, but this is computing i guess!

just an advice: leave those "optimized" and "omega" drivers alone. i know a few people who were using them and had very bad experiences with them  :frowning: anyways, such drivers don't belong in a development environment.

Then again for some people they fix a lot of problems with jME (espc. laptop users)

But I'd try to the normal ones first.

i think ive currently got a beta build, but i dont know for sure (it said so on the website, but i think the download link mightve been mis-directed) ah well, if it works im happy - but then i said that a month ago, so we shall have to wait and see :)

mtm :)