SDK 3.1.0-beta1_xbuf-SNAPSHOT Incomplete draw buffer bug

Hi, ppl! I va tried new (for me) SDK 3.1.0-beta1_xbuf-SNAPSHOT and get this bug at console just after the SDK started. I’ve read forums’s questions about “Incomplete draw buffer” bug, but unfortunately there r all was not about my situation. Tthis is what i get in console right after SDK started:

Running on jMonkeyEngine 3.1-beta1
 * Branch: HEAD
 * Git Hash: 310f4db
 * Build Date: 2016-04-25
LWJGL 2.9.3 context running on thread jME3 Main
 * Graphics Adapter: aticfx32
 * Driver Version:
 * Scaling Factor: 1
OpenGL Renderer Information
 * Vendor: ATI Technologies Inc.
 * Renderer: ATI Radeon HD 4300/4500 Series
 * OpenGL Version: 3.3.11672 Compatibility Profile Context
 * GLSL Version: 3.30
 * Profile: Core
Audio Renderer Information
 * Device: OpenAL Soft
 * Vendor: OpenAL Community
 * Renderer: OpenAL Soft
 * Version: 1.1 ALSOFT 1.15.1
 * Supported channels: 64
 * AL extensions: AL_EXT_ALAW AL_EXT_DOUBLE AL_EXT_EXPONENT_DISTANCE AL_EXT_FLOAT32 AL_EXT_IMA4 AL_EXT_LINEAR_DISTANCE AL_EXT_MCFORMATS AL_EXT_MULAW AL_EXT_MULAW_MCFORMATS AL_EXT_OFFSET AL_EXT_source_distance_model AL_LOKI_quadriphonic AL_SOFT_buffer_samples AL_SOFT_buffer_sub_data AL_SOFTX_deferred_updates AL_SOFT_direct_channels AL_SOFT_loop_points AL_SOFT_source_latency
Pausing audio device not supported.
Audio effect extension version: 1.0
Audio max auxiliary sends: 4
java.lang.IllegalStateException: Incomplete draw buffer.
	at com.jme3.renderer.opengl.GLRenderer.checkFrameBufferError(
	at com.jme3.renderer.opengl.GLRenderer.updateFrameBuffer(
	at com.jme3.renderer.opengl.GLRenderer.setFrameBuffer(
	at com.jme3.renderer.RenderManager.renderViewPort(
	at com.jme3.renderer.RenderManager.render(
	at com.jme3.gde.core.scene.SceneApplication.update(
	at com.jme3.system.awt.AwtPanelsContext.updateInThread(
	at com.jme3.system.awt.AwtPanelsContext.access$100(
	at com.jme3.system.awt.AwtPanelsContext$AwtPanelsListener.update(
	at com.jme3.system.lwjgl.LwjglOffscreenBuffer.runLoop(
Returning hash code of content
Reading welcome page content from web failed! No subject alternative DNS name matching found.
Checking page id 0 vs stored id 0

Is anybody have same issue or it is just me have bad luck or broken viedo card? I have to say that JME 3.0 SDK works ok

Everything except that exception seems normal.

Does this happen all the time?
I can’t really help you, since this is something related to the engine itself, so we have to see if the core guys have an idea.

Yes it is keep happening every time i run SDK. I have tried driver update, but it won’t help. Looks like this is some kind of Video Card bug or internal engine bug. Gonna wait some core contributors responce. Anyways thx for reply

Isn’t any core contributor have a one look? :slight_smile: Guys? Is this problem is only on my video card?

Are you using an AMD card?

Looks similar to this:

Thx for reply. Yes my card is AMD on then computer where i can’t use JME SDK 3.1.
And yes again this issue is similar. Dont’t you know is someone have plans to fix it in SDK 3.1?