SDK Blender Importer Issues

Hi there,

I’m having issues with the SDK’s blender model importer. It crashes when attempting to load a blend file.

Some files seem to work but the majority seem to crash the entire sdk. Even models I had imported successfully before
seem to be having issues with importing.

Are there known issues with the importer?

Thanks for reading,

Do you get some sort of error message?

From within the SDK no.

If I run from the console and don’t exit it I get this.

java.lang.OutOfMemoryError: GC overhead limit exceeded

EDIT: I removed the subdivider modifier in Blender and the model imported. Though it still seemed to cause a lot of work for my PC.

I once had the same problem. But I don’t remember how I solved it (if I did at all). I think it had to do something with modfier as well. Anyway, did you try to export via ogre or xbuf and convert it to .j3o in jME?

I didn’t think of Ogre.

I tried obj but it didn’t export skeleton.

I did get it to work but removing the modifier. I’ll be sure to remember ogre for future issues.

Did you at least try it? Does it work for your model?

  1. Which Version of the SDK are you running? Until (including) beta1 you could have a frozen sdk due to the triangulation which happened.
  2. OutOfMemoryErrors should be well known to a Java-Developer since those are about fine-tuning the parameters of java’s memory management. and Understand the OutOfMemoryError Exception → GC Overhead → More Heap Memory.

This is usual: Your Heap is too small but by GCing heavly it tries to work with that constrainted memory.
It’s also usual that importing a big model (I assume 4096px textures and > 100k Verts) takes some time. Especially the Subdivision Modifier where you have to generate many more verts.
Applying them in Blender also helps (Maybe you want a seperate .applied.blend file which you always overwrite.

Oh and Note: If it was a Bug/Issue: The Most Important thing is missing: The Stacktrace.

I don’t have the ogre exporter installed apparently.


I’m using 3.1.0 Beta 1 snapshot.
There was no simple stacktrace. Just the full heap dump.
If I just need to permanently increase my heap size I’ll do that.
It’s just an odd thing because previously using the blender importer on the 3.0 sdk didn’t have the same issue.

Same for me!