Simple World Editor: Can't save/load?

Hey guys, I’ve downloaded SWE 0.18, and it looks pretty cool! It’s really easy to use. The thing is, I made this “great” scene, and I couldn’t save it lol. The file explorer sort of crashes…
I re-opened the software, and tried to save an empty scene, and when I click on save or load, the file explorer shows up, but it’s like if it doesn’t have focus… I can see the cursor blinking, waiting for me to write the name of the file, but I can’t write, nor click in the file explorer nor the software anymore. After that, I only could exit using the Task Manager.
I’m on Windows 7 64 bits.

Has anybody experienced an issue like this?? or does someone knows how to fix this?
Ive tried running the soft in administrator mode, but it seems to be the same…
Thanks guys.

Hmm, this worked fine for me. Can you reproduce the problem running it in a console to see if there’s any exceptions?

I got your PM. Just let us know if all is ok. And if you have issues with NONEnglish characters - give us to know. We will try to fix it.