[SOLVED] Asset manager gives error when trying to load custom texture or material

Hello, I have a problem - when I’m trying to use texture via mat.setTexture("ColorMap", assetManager.loadTexture("Textures/stone.jpg"));.
And I receive:

Exception in thread "Thread-0" com.jme3.asset.AssetNotFoundException: Textures/stone.jpg (Flipped) (Mipmapped)
        at com.jme3.asset.DesktopAssetManager.loadAsset(DesktopAssetManager.java:371)
        at com.jme3.asset.DesktopAssetManager.loadTexture(DesktopAssetManager.java:391)
        at com.jme3.asset.DesktopAssetManager.loadTexture(DesktopAssetManager.java:401)

I’ve tried to change the path to assets/Textures/stone.jpg, /Textures/stone.jpg, but nothing works.
My project structure is:
Screenshot from 2021-09-29 16-48-00
Also, I don’t use the jme IDE, only vscode.
OS: Linux

Your application is not depending on your assets and so they aren’t on the classpath at runtime.

What that means depends greatly on the parts you haven’t included in your post… like build file, etc.

Thanks, I’ve added


to my pom.xml, and now there are no errors.