[SOLVED] Blender export help

Question for anyone who might know, I am loosing my mind on getting a model to export. I am not a blender expert by any means. Blender 2.83

Here is the model I have, in blender.

I export with these settings:

And, if I re-import back into blender, this is what I get:

Or in jme:

I have never had this issue before with blender, I am sure I am doing something stupid, but I have no idea. Any help would be appreciated.


1 Like

I finally figured it out!

Select all objects, CTRL+A, Apply All Transforms


Nice looking model, you build that?

No, it is from kitbash: Steampunk – KitBash3D

1 Like

POLY COUNT 8.7 Million

Crap, one model and your done.

Edit: It is very nice looking though.

I was facing similar problems when trying to export my Models in .fbx & then importing them into JME SDK 3.2.4 , So i used .obj & import & convert them to .j3o in JME SDK 3.2.4

i am using blender 2.83.5.

this supposed to be a submarine :

now its a military Gun :joy: :joy: :joy:

Conversion from .obj to .j3o :

So, i guess if you faced this problem again , try changing your export extension

Except they already solved their problem the right way rather than using an antiquated and low-featured format.

1 Like

well its all in Wiki. When i had issues myself i usually look step by step on wiki if i skip something.

@Pavl_G GLTF works best for me, and its new standard of export here. But best if Blender 2.8+


Iirc, that is for all the models combined that come in the kit, which is a lot of models.

They are a bit heavy on the poly count though, so lod levels are a must.