[SOLVED] Build Scripts troubleshooting

HI everyone,

I’m working on fixing the build installer scripts and I might attempt to automate creation (at a later date).

My question is: Do i need to use Java JDK version 8u144? I’ve changed my version to 8u152 which also removes the need for XAR to compile the macos jdk.

Locally I’ve fixed download-jdk(dot)sh and tested it working multiple times, im currently testing the other scripts(gradlew buildsdk failed out so im working on that) . I just need to know if Jmonkey is dependent on version 8u144 before making a pull request.


Judging by previous commits no this does not matter. I’m off to work on the gradlew build process.

I got the build process working now, it installed correctly and the sample game starts up so that is progress.

Hey, first of all:
What is it that you are trying to fix? Since so far technically everything used to work (at least in the travis environment).

Especially what happened to buildSdk? Why did it fail?

And yeah it could be that Oracle changed the packaging of JDKs again just like they recently changed the URLs to annoy us :smiley:

Edit: Now I noticed it, oracle indeed broke our jdk extraction code, but what happened to buildSdk?

Build SDK was my fault, i was getting missing errors for the core libs. After some reading of the documentation and an embarrassingly in-depth deconstruction of the gradlew process I saw that I built the engine incorrectly. Once I built the engine correctly everything else started working.

The over all goal was to just gain knowledge about the engine and how its built/how to make changes.

I made a pull request but it can be denied as i changed the JDK version and removed the Xar stuff from the linux jdk build as it is not needed for jdkversion 8u152. Again the goal was to just get more involved with Jmonkey.

Hey, I didn’t want to sound rude or something, I just wanted to make sure what the exact issue was since at the time of upgrading to u144 everything worked. For some reason they actually changed an existing file (which I cannot understand of oracle).

Your PullRequest is fine and actually helps us fixing the travis builds (just a note: it was the mac jdk which needed xar).
I’ll address specifics in the PR :slight_smile: