[SOLVED] Cannot run application from SDK

I am running JME from ubuntu "4.15.0-91-generic #92-Ubuntu SMP "
I have version “jMonkeyEngine SDK v3.2.1-stable-sdk3”

It has been some time since I have been in JME but this did work in the past. I don’t know if there have been updates in the intervening time.

I can run java from the command prompt. I can run java from netbeans. I can build while in the SDK. I cannot run any application from the SDK. I even tried creating a standard java project and that did not run in the SDK. I did set the default project in the run menu. If I build the project, it leaves some text to run the application from the command prompt. This works from the command prompt, but not from the SDK. When I click run I do not get any text in the log. I searched for similar problems but they had text in the log. I checked my classpath and they both look fine. Both javac and java are in the same directory so JME must be able to get to it. I am not sure what else to check on. Does anyone have any ideas?

Maybe you can try uninstall and reinstall jmonkeyEngine SDK ?

Somewhere on the menus was “IDE log” item, you could check that if you get some error message. Without any error or warning this feels a bit too difficult to us for solve.

Also what Simon says is valid, there are also newer versions of the SDK available.

since it would take awhile I figured I would wait to see if there were other suggestions. I opened View > IDE log. Cleared it. clicked run 400 times. No log entry.

I prefer to use the version from the repo. I am on the newest version in the repo.

Welcome to this community ! :smiley:
I am also a beginner :sweat_smile:, but I suggest you install the newest version of jmonkyEngine SDK. Maybe your problem will be solve.

1 Like

Yep, my suggestion also:

If by repo you mean the Ubuntu repositories etc. Also purge and re-install could be one.

1 Like

ok, I’ll give that a try, it may take some time for all that. but I’ll get started.

1 Like

ok now on “jMonkeyEngine SDK 3.3.0-v3.3.0-beta1-sdk1-SNAPSHOT” and it works as expected. @Simon you got it.

1 Like

Actually we’d have v3.2.4-stable-sdk1 as last stable version, but on Netbeans 8 with Java 8 support, so probably having the same problem you were experiencing.
Which Repo are you talking about?

I thought that I had installed it from the ubuntu repository but my install notes say I downloaded a .sh file that did the install for me.

1 Like