[Solved] Can't play blender character model with bvh

I animate my blender character model with mocap (bvh.). I import to jme 3.0. I try view, the model shows but the animation won’t play. It moving but no animation. What’s probably wrong in making this model on blender? Please help.

A screenshot of model while playing animation in jme may help a lot to debug the problem.

Bake the BVH animation to a normal bone animation. (I don’t know how exactly that works, google it if you don’t either)

I think you can use the MakeWalk utility for Blender to bake mocap animations. It’s a plugin that can be found at the MakeHuman website.

You also should make sure that the animation is really added to the NLA-Track. Make sure that this one is really applied to the character model. Also look that you applied location, rotation and scale of your object.

Sorry I think I broke my jme3.0 . I need to re instal it again. So I can upload screenshot now

@mathiasj its mh and i use MakeWalk. I didn’t know if I need to bake it. The problem is seems they still working on the documentation. But let me check out again what I can do with that.

You need to bake your animation in blender.
Select Rig then go to this menu Object → Animation → Backe Action
then import it to jme.
now you should have your AnimControl next to your mesh .
like this:

if you are using make human search the forum about import Make human to jme you will find useful info.

I recommend to use jme 3.1. it has some improvement regarding blender importer.
you can download latest version here : Release 3.1-beta1-SNAPSHOT · jMonkeyEngine/sdk · GitHub

1 Like

you may find something useful in this old post.

1 Like

There’s a complete tutorial series on how to do that here https://vtsdemozone.org/2016/02/18/using-bvh-animations-in-jme3/

unfortunately @thetoucher was right. The animation plays smoothly in Blender but can not be imprted to JME. I still courious what I can do with this .bvh.

can you upload your model somewhere so I check it ?

Okey. Let me see what I can do. Beside that, seems I broke my JME 3.1. It’s not installed properly or something. I am going to to fix it.

I try JME 3.1 zip version. I am not sure what causing the problem. Here the screenshot.

What the red text means?

@Ali_RS here you can try. https://bitbucket.org/melo_dramatis/basicgamejme/downloads
I didn’t fix the animation completely. So they are look weird in some part.

Have you tried the tutorial from Rhymez already?

It plays with no problem for me.
I converted it to .j3o in code not using SDK blender converter (when using SDK blender converter it crashed and i needed to restart SDK)
So first I loaded .blend using assetManager.loadModel("Models/upload/Female/fanime01.blend");
then i save it to j3o. look here for saving http://davidb.github.io/sandbox_wiki_jme/jme3/advanced/save_and_load.html

and it plays ok.

As you see I am playing animation from last AnimControl (I mean from the last Node “Female:Proxy741”) if you play it from other Nodes it will not play animation in SDK.
(it is a bug and one of developers works on it)

@Domenic I have tried, but I am slow with video tutorial. So I still don’t understand how to do that.

@Ali_RS thanks for the information. you mean I need to use gradle and netBean, not that SDK beta? I tried with SDK, after add the blender library, using assetManager.loadModel I can load the blender model but no texture. And fail to save as j3o.
I have problem with gradle. Let me see what I can do.

No No. I do not mean that. Sorry if I my post was not clear enough for you.
I just wanted to say that I tried to convert your blender to j3o using this way and it crashed:

So I suggest you to load it in your code like this :
Spatial femail =assetManager.loadModel("Models/upload/Female/fanime01.blend");

You should first move your blender model and all textures with it inside your “assets” folder of your project so that JME can load it.
then open blender model and :

then go to texture folder for that model


now save your blender file and try to load it in jme. now textures should load properly.

I still don’t understand. I load it like teapot .obj on HelloAsset tutorial but .blend file. and run it. I see the model on open window. Still can’t view on sdk. I crash when I try that.
Edit: Sorry I’ll try again.

Like this…

Edit : sorry, I made mistake with the path of saving the .j3o file on code.