[SOLVED] Crash upon crash (Asset renaming, code completion, drag drop asset inside scene)

Hello everybody,

First of all I’m very glad with everything this project provides. Big thanks to the developers.

But I’ve stumbled upon quite some bugs, which makes it very hard to work with the jMonkeyPlatform.

They all give somewhat the same errors inside the terminal and I’m getting both an error log and a core dump.

The core dump is 506 mb large and I hardly believe that it will do any of you good. so here is the error log instead.

Error log:


Almost always when I drag and drop an asset in to the scene editor, rename a placed asset inside the scene or use particles. jMonkeyPlatform crashes and gives me some explanation in the terminal and this error log.

This also sometimes happens when I’m programming something and code completion comes up.

This last piece of information leds me to believe that it isn’t an opengl problem, like somebody said in my previous post.

Also, when I’ve added multiple assets and want to move them around. The selection changes to another asset for some reason. For example:

  1. I’ve added a box to the scene.
  2. I’ve added two more boxes to the scene.
  3. I select one of the boxes in the outliner of the scene.
  4. I press the little move button, so I can start moving it around.
  5. I start dragging on the move cursor of the box, with intentions to move the box.
  6. The selection changes to another object and I can’t move the box around.
  7. The selection always changes back to the same object.

    (though this doesn’t provoke a crash, I did wan’t to mention it. The more bugs the merrier ;D)

    My motivation to post something about this again is that it’s practically impossible to work with the platform as is. Somebody said that these events didn’t occur too often, but I conclude differently.

    Now some background information.

    I’m using a Mac Mini with Ubuntu 11.10 32-bit

    I tried the following jdk’s:

    openJDK 1.6

    openJDK 1.7

    oracle JDK 1.6

    oracle JDK 1.7

    All of them gave back the same results, though it happens less often when I’m using 1.7

    The error log comes from openJDK 1.7

    Best regards,


Did you try switching between the canvas and panel settings in the “OpenGL” settings of the SDK?

1 Like

Hmm, so far everything works better. No crash yet, which I normally had.

Though I thought I turned the Heavyweight canvas on before. Hmm strange.

Thank you :smiley:

Greetz Ertyui

Though the “Box problem” isn’t solved by this…