[Solved] Does the Blender importer work with Animations?


#41

I created a NLA strip for my animations.


If you need help on that ask.

Note that the tracks are under the selected armature.
Note that there is a 4 frame gap between tracks.
Note that the last track end frame matches the timeline length.
Note that the bone type is octahedral.
When exporting select the armature and model.

In the exporter check selected only.
In the exporter make sure that start frame = 0 is not selected since blender starts at frame 1.


#42

Ya. I’m already there. For some odd reason even after I tell it to use Linear Extrapolation on the particular channel it sticks with Cubicspline. Rather frustrating I must say. I’m debating about just editing the gltf file directly to get it to be Linear instead of Cubicspline.

Edit: Well that didn’t work either. Argh.


#43

Got it. So what I needed to do was manually set it to Linear Interpolation in Blender using the “T” menu.

Now I just need to frag the mess I created in the file and redo the animations.


#44

Solved?


#45

Almost. Just working on the getting animations to work thing now. Once I have that working I’m going to write down the steps I took here then mark as solved.


#46

So I have the model imported, worked out how to reference animations, got an animation looping.

The model is all weird mind you but it’s all there. So I think I can mark this as solved and I just have to continue plugging away at the model itself to sort out why things are so… weird model wise.

Thanks again for everyone’s help!

I’ll post a step by step in here once I’ve sorted out the model tomfoolery.