[SOLVED] Following Hello Assets tutorial but the asset folders and src are missing

So, here’s the deal, I’m trying to get through the beginner’s tutorials, and the code provided should just be able to be put in and work, right? Well it’s unable to pull assets from the asset directory and when looking in the folders, they are all empty. I tried using jme 3.4 build, jme 3.6.1, reading over the asset importer stuff, gradle builds, ant builds, nothing. I even imported a basic project from GitHub to try and import the assets from that project but it’s the same thing and I’m feeling…really silly. I’ve included a screenshot so maybe…I dunno someone might be able to tell me what I’m doing wrong? I’ve tried Gradle, I’ve tried ANT, different versions…

Also the error:
com.jme3.audio.openal.ALAudioRenderer initOpenAL
INFO: Audio Renderer Information

  • Device: OpenAL Soft
  • Vendor: OpenAL Community
  • Renderer: OpenAL Soft
  • Version: 1.1 ALSOFT 1.15.1
  • Supported channels: 64
  • AL extensions: AL_EXT_ALAW AL_EXT_DOUBLE AL_EXT_EXPONENT_DISTANCE AL_EXT_FLOAT32 AL_EXT_IMA4 AL_EXT_LINEAR_DISTANCE AL_EXT_MCFORMATS AL_EXT_MULAW AL_EXT_MULAW_MCFORMATS AL_EXT_OFFSET AL_EXT_source_distance_model AL_LOKI_quadriphonic AL_SOFT_buffer_samples AL_SOFT_buffer_sub_data AL_SOFTX_deferred_updates AL_SOFT_direct_channels AL_SOFT_loop_points AL_SOFT_source_latency
    Dec 01, 2023 12:38:20 PM com.jme3.audio.openal.ALAudioRenderer initOpenAL
    WARNING: Pausing audio device not supported.
    Dec 01, 2023 12:38:20 PM com.jme3.audio.openal.ALAudioRenderer initOpenAL
    INFO: Audio effect extension version: 1.0
    Dec 01, 2023 12:38:20 PM com.jme3.audio.openal.ALAudioRenderer initOpenAL
    INFO: Audio max auxiliary sends: 4
    Dec 01, 2023 12:38:20 PM com.jme3.app.LegacyApplication handleError
    SEVERE: Uncaught exception thrown in Thread[jME3 Main,5,main]
    com.jme3.asset.AssetNotFoundException: Models/Teapot/Teapot.obj
    at com.jme3.asset.DesktopAssetManager.loadAsset(DesktopAssetManager.java:385)
    at com.jme3.asset.DesktopAssetManager.loadModel(DesktopAssetManager.java:439)
    at com.jme3.asset.DesktopAssetManager.loadModel(DesktopAssetManager.java:444)
    at jme3test.halloworld.HelloJME3.simpleInitApp(HelloJME3.java:25)
    at com.jme3.app.SimpleApplication.initialize(SimpleApplication.java:240)
    at com.jme3.system.lwjgl.LwjglAbstractDisplay.initInThread(LwjglAbstractDisplay.java:139)
    at com.jme3.system.lwjgl.LwjglAbstractDisplay.run(LwjglAbstractDisplay.java:221)
    at java.base/java.lang.Thread.run(Thread.java:833)

Dec 01, 2023 12:38:20 PM com.jme3.system.JmeSystemDelegate lambda$new$0
WARNING: JmeDialogsFactory implementation not found.
Uncaught exception thrown in Thread[jME3 Main,5,main]
AssetNotFoundException: Models/Teapot/Teapot.obj

I figured it out, I /AM/ silly haha I didn’t import a library because I thought it was already added