[SOLVED] .glb animation export

Hello. Im making my models in blender 2.9. The problem is, whenever i export them to .glb, it only exports maximum of 3 animations. The animations are keyframe animations, dont use inverse kinematics and all have fake users. Does anyone else face this problem and has an idea how to fix it?
The animations that get exported DO WORK properly.

If you export as a gltf + glb, can you post the gltf file? This sounds like it may be an issue with the gltf exported in blender.

you can try use .gltf instead of .glb and tell us if it works there.

we anyway if possible would like to have demo model that does not work.

i remember .glb had some issues but were fixed, but maybe in 3.3 while you use 3.2? (but no, you need use 3.3 since blender 2.9 export would not work in 3.2 i suppose)

I recall one time my animations were not getting exported because they had a 0 in front of them, similar to the way that the Fake User puts an ‘F’ in front of the animations as they’re listed in Blender.

I am not sure what either indicates, and only have a faint memory of this happening a long time so my apologies if that isn’t relevant to your issue.

Im using jme 3.3

sorry its not the model, but thats all i can provide now. As you can see, there are 4 animations, each having a fake user, and when i try to export the model to gltf/glb (doesnt work with any of these) it exports only 3 animations. Moreover, it is 2 animations made first + 1 animation currently chosen in the moment of exporting. Same thing happens with different models, so its not a matter of this particular model

can i see your NLA tracks?

sure, there you go:

i see 3 armature animations in NLA track.

im not sure if NLA track was needed for animation export, but if i remember correctly, i always put all animation in single track, or just each track 1 animation. Anyway try put all animations into it.

Please note “AttackPose” seems to have some NON-ARMATURE animations that will not be exported.
Untill its morph shapes that can be exported.

thanks, will try it now!

1 Like

it is not the issue but thanks for answering

Thanks, this was the issue. I wasnt familiar with NLA tracks, even unaware such thing existed. Thanks a lot.

solved: in Action Editor clicked “Stash” (next to action name), and exported as .gltf. worked. (doesnt work with .glb)


I export morph shapes outside of animations regularly (I added support for it in the gltf importer), do they not work in animations?


hmm, did i said somewhere it dont work?

if i did, im sorry, i just mean that he/she had “object animation” that wasnt morph or skeleton animation.


what do you mean with " (doesnt work with .glb)"

if glb have issues(in 3.3), it might be worth to report them on github.

1 Like

It seems like glb issues would be on the export side as JME essentially uses the same code for both.

…but I guess we’d have to know more details.