[SOLVED] Gltf/glb textures

i’ve got a problem with textures using .glb. When i import a model i can see the texture on the preview, but when i run the game, the model is just completely blank. It doesnt add the texture file to any assets folder.

I am using blender 2.91 and my models were loaded into JME 3.3 if that matters.

1 Like

Are the textures packed into the glb file, or are they separate? Have you tried exporting as gltf with textures included in the file?

Also just in case it’s relevant, gltf will use PBR so you will need a light probe or all ambient will look dark. Your regular scene looks like it might not have any light and only ambient so I thought I would check.

Right, will check it right now

Yes, it was about light, but another problem showed up. The textures dont load properly on my model for some reason

The texture on the skull doesnt seem to work properly (it’s not the because of the lighting angle because i tried different positions)

And thanks for solving my problem with dark textures !

1 Like

Does it look correct in blender? What are your export settings?

it does look correct in blender, and i dont know what my export settings are. Could you please tell me how to check that?

  • the texture does look as it should everywhere on the model apart from the skull.

now i noticed that painting on the head of the skeleton doesnt work properly.

i made a swipe with purple color on the place marked with green ellipse and the texture didnt get painted in the place i wanted it to, but on the face and parts of the helmet. Have you got an idea why it happens and how to fix it?

That sounds like messed up UVs or being unfamiliar with how the painting mode works.

When you go to File > Export > GLTF, a file chooser appears in which you can pick the file name to save to. On the right side of the file chooser, there are various GLTF export options.

thats what it looks like in-game when i painted the whole model in blender (its a problem of the model, but i dont know what can it be)

Do you have a separate UV set for the head maybe?

This is artist issue.

it can be caused by many things, for example

  • related with wrong “normal/face direction”
  • overlap of mesh(dupplicated mesh where one is black)
  • broken ambient occlision map (but its probably not it)
  • metalness set to 1 for head, while light probe is also black.(torso might have metalness 0.5 so its not black)
  • head using different material that is black cause of no painted textures

Fact is, you have torso working, so just look what you did wrong for head.

1 Like

nope, the model was unwrapped as one.

1 Like

yup, it was wrong faces direction on the skull. Shift+N in blender fixed the problem. Thanks!

1 Like