[Solved] How do I add the assets into a built project?

I have built a project in a ZIP file:

Problem is, the resources are not in this ZIP file. So, when I run the executable, it closes as it cannot find the first resource I attempt to load.

I have tried adding resources manually,

But neither of these have worked either.

How can I create a ZIP file that has the necessary resources to click the “exe” file and run the game?


This should usually work out of the box. You actually need the lib/assets.jar file in your distribution.
Isn’t it under app/lib/assets.jar?

Try to manually put that assets.jar in different locations

Unfortunately, doesn’t work. :frowning:

Wait, I know why. I just took a look inside the Assets.jar file.

Why are the correct models not there? I have far more than this in my models folder in the SDK:

What is going on here?

It’s only taking Models (j3o) and Textures.
The .obj/.mtl aren’t JMonkey Models and as such aren’t included into your assets (they would’ve be converted at any launch).

Just convert them as j3o and they are there.
The alternative would be to modify the “asset excludes” under the Project Properties → Assets but it’s not recommended

So I modify:


Edit: Just modified it, and the game runs perfectly, thank you so much!! :smiley:

BTW, J3o actually has slower loading times compared to obj in some scenarios, when I have tested it.

Or right click on the obj’s and have them converted to j3o :wink:
That way you could also modify the j3o file (e.g. Materials, …)