[SOLVED]I no longer see android targets in drop down list

I thought I had this working before but for some reason I can no longer deploy to android

In the Project Properties : Application : Android I can not see any values in the Android Target Drop down.

Also what does the Run Android Target configuration button do? I push it and nothing.

Can anyone give me some pointers.On where it gets the list of Targets from and if I am just missing something easy.
Is there a log for the jMonkey SDK that might show some errors?

Note: I can compile and run other android apps on my nexus 7 using the Android SDK.
Note2: I went to the JMonkey SDK : Tools : Options : Misc and filled in the sdk location

JME has lost the path to your Android SDK.

You can reset it under tools → options → mobile

There will be a box for you to set the path of your Android SDK

1 Like

It is still not working. I downloaded the android SDK again. jMonkey | Tools | Andorid SDK Manager launches the SDK Manager so I think the path is correct.

… Also my screen says Android instead of Mobile

Solved. I was filling in the SDK in the Options misc/android field. There is also a Options Mobile SDK fields

I also had to create a new project and go to project properties and select Enable Android Deployment then a separate project called mobile appeared.


1 Like

If even the above method doesn’t worked out for you, then you must be missing locating Gradle location in JME3.
Let me explain you in brief:

  1. Go to Tools->Options->Misc

  2. If gradle is appearing as an option in the within tabs, then locate the gradle location there by clicking “Browse”. It was present at “/android-studio/gradle” in my case.

  3. In case gradle is not showing up in within tabs options, then go to Tools->Plugins->Available Plugins and then install “gradle” from there.

That’s it build you project.
Hope this’ll help you too, as it did in my case.

1 Like