[SOLVED] Illegal reflective access on one system (from core)


#1

I have my game uploaded on Itch.io. It executes, but on one of my systems, I get this in the log:

WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by com.jme3.util.ReflectionAllocator (file:/C:/Users/asser/AppData/Roaming/itch/apps/Subspace%20Infinity/libs/jme3-core-3.2.3-stable.jar) to method sun.nio.ch.DirectBuffer.cleaner()
WARNING: Please consider reporting this to the maintainers of com.jme3.util.ReflectionAllocator
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
WARNING: All illegal access operations will be denied in a future release

Logged here:

And my game just wont let the client attach:

image

But if I try from my laptop, it works just fine (also from Itch.io)…

Any ideas?


#2

Do you have the same version of java on both systems? Or does one have 11 and one have 8 or something?


#3

Ah - thanks. That’s probably it.


#4

Hhmm…

malfunctioning system:

C:\Windows\system32>java -version
java version “1.8.0_201”
Java™ SE Runtime Environment (build 1.8.0_201-b09)
Java HotSpot™ 64-Bit Server VM (build 25.201-b09, mixed mode)

working system:

C:\Windows\system32>java -version
java version “1.8.0_211”
Java™ SE Runtime Environment (build 1.8.0_211-b12)
Java HotSpot™ 64-Bit Server VM (build 25.211-b12, mixed mode)

If I run the game from the SDK it works (on the system where itch.io fails)

Edit: Let me check SDK


#5

Okay, so SDK is using 1.8, itch.io is launching with jdk-11.0.2… (OpenJDK)

Have to get rid of the jdk-11


#6

Can you try with LWJGL3 to see if that happens ?


#7

I’m using jme3-lwjgl:3.2.3-stable


#8

This would be LWJGL 2


#9

tbh yes that issue is because latest java versions try to lock us out on reflective access to internal buffers, but that’s only a warning, it should NOT be the source of the ConnectionException, for that you might have to dig into application.log.


#10

Okay, but my issue is solved when removing OpenJDK (v11), and running with jdk 1.8. I dont want to re-install OpenJDK and re-introduce the issue to dig any further :slight_smile:


#11

Yeah, there could be other JDK version incompatibilities that affect the lower level network connections.