[SOLVED]Java heap space error while loding model

hi guys,

i have a problem.

Usually i can export via blender my model and convert the mesh.xml to j3o.

Usually my programm loads the model fine… but recently i get everytime i convert my mesh to a j3o, my programm throws the heap space error.

well i m aware of Xms1024 option, but thats no use.

The sceneviewer can load it aswell…

Models i converted earlier work just fine too.

So i dont quite understand whats wrong here…

The code shouldnt be the problem and the argument as i said didnt worked as well…

any1 out there with the same problem?

(i know u cant help me, if i dont post anything … so i load up in some minutes 2 example spatials)



here the dummy files :


i can load Dummy1 but not Dummy2 (be careful, the files itself are labeled the same)

however… if i convert Dummy1 again, i cannot load it anymore )


well i tried alot of these options …

nothing worked

terry said:
well i tried alot of these options ...
nothing worked

You will have to be more specific. See, the option you stated will not help you even slightly since it only sets the minimum heap size to 1k... where as the option Normen mentioned will increase the maximum heap to 1 gig.

So, what options have you tried exactly and how big is your model?
terry said:
well i tried alot of these options ...
nothing worked

Just use the one I posted, it will work..
@pspeed He said it loads in jMP and it "only" has -Xmx512m ;)

well thx so far for response

i figured out that it has something to do with my jmp version …

well a new try on my pc (instead of my laptop) and the error didnt accure at all…

sorry for the trouble

and thx again for the responses!

i really appreciate it