[SOLVED] ”Java Se platform binary has stopped working” on Win 7 x64 when running tests

Hi all,

I wanted to get on with JME 3, so I downloaded it and created a “Jmetests” project to test it out.

Most of the tests successfully run and I can see the output as well as interact with them. However when closing the game window via the “x” button, an windows error message pops up:

“Java platform SE binary has stopped working” with two choices - “Check online for solution” (No solution is available, tried it) and “Close this program”.


Problem signature:

Problem Event Name: APPCRASH

Application Name: java.exe

Application Version:

Application Timestamp: 4e897c9a

Fault Module Name: OpenAL32.dll_unloaded

Fault Module Version:

Fault Module Timestamp: 4e894548

Exception Code: c0000005

Exception Offset: 09dbd03f

OS Version: 6.1.7601.

Locale ID: 1026

Additional Information 1: 0a9e

Additional Information 2: 0a9e372d3b4ad19135b953a78882e789

Additional Information 3: 0a9e

Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

This of course kills the testChooser dialog as well. The java log indicates no problem.

With the test “class jme3test.app.TestApplication” the problem is even more severe, cause it crashes at the beginning of the test right after it displays the game window. The details of the message:

Problem signature:

Problem Event Name: BEX64

Application Name: java.exe

Application Version:

Application Timestamp: 4e896edc

Fault Module Name: OpenAL64.dll_unloaded

Fault Module Version:

Fault Module Timestamp: 4e894561

Exception Offset: 00000000083f5fda

Exception Code: c0000005

Exception Data: 0000000000000008

OS Version: 6.1.7601.

Locale ID: 1026

Additional Information 1: b4ee

Additional Information 2: b4ee5de6a2322745523997a782b35692

Additional Information 3: c96a

Additional Information 4: c96ae12ea73bfecdac2b3ff34e9f928a

Can you give me directions as to why this is happening? What more logs would you need to diagnose the problem? Here are the PC specs, if they are of any help:

Win 7 x64bit professional

Laptop: Dell Vostro

Video: Ati Radeon HD 6630M - latest driver

Java JDK 1.6 update 29 x64 - tried JDK7u1 x64 as well as JDK 1.6 u29 x32 but the errors appear there too.

I guess this is a specific problem, cause no one else seems to be having issues with win 7 x64 on this forum.

I have tested on my work PC which also has win 7 x64 and amd radeon card and the same thing happens there too.

I get JRE crashes on Win7 x64 when I debug, but not when I run release code. I just ignore it and carry on, it hasnt affected my debugging.

This is a LWJGL 2.8.1 bug, its already fixed in the nightly builds, LWJGL 2.8.2 will be out soon.

1 Like

There’s currently a problem with LWJGL affecting Windows 64-bit, we’re waiting on a fix from them. You should be able to run things on a 32-bit JVM until the fix gets released upstream.

Edit: It appears that @faust beat me to it :slight_smile:

1 Like

Thank you for the quick reply. I’ll try to use latest LWJGL builds later to see if that fixes my problem. Any pointers how to do that would be welcomed.



When using the latest build of LWJGL this problem indeed stops appearing (most of the cases). I did that by replacing the files in the jar jME3-lwjgl-natives.jar. (Don’t know if that is the correct way to do that). Now on exiting most tests I don’t get that nagging window. Therefore - SOLVED.

Oh, I forgot to thank everyone who helped :slight_smile:

If you want to properly thank everyone who helped thumb their post up. :slight_smile:


Thanks, I’ll keep it in mind.

Hi there, I’m suffering the same problem. I can’t even open JME’s SDK. I’ve just build a PC specifically for JME development, so it’s pretty frustrating! Getting the latest release version of LWJGL (64 bit) and injecting it via Neandertal’s method didn’t help me. Neandertal - did you use a nightly build of LWJGL? If so, do you know where the nightly download shortcut is on their website? I can’t find it. Or did you use the 32 bit version?

I’m using JDK 7, Windows 7, both 64 bit.



You don’t need to “inject” anything, just update, lwjgl 2.8.2 comes with the update and gets properly used afterwards. If not, try deleting the all file from the SDK settings folder (or the whole settings folder).

1 Like

Thanks :slight_smile:

I just updated the JME3 SDK to the latest nightly build and still get this error nearly every time I close an application. (Win7 x64)

How can i check wich version of LWJGL I have installed / is used by the game?

@normen: What is the “the all file from the SDK settings folder” you suggested to delete?

“dll” file I meant, darn correction :wink:

Thanks normen for clearing up what you meant.

But anyway I could not find any LWJGL dll to delete, but switching Java from x64 to x86 seems to solve the problem for now.

Mine is windows 7 x86, but the error occurs almost everytime I quit the game by both Alt+F4 and “x” button!!! !-_- >:(

Disabling the AMD Gaming Evolved stuff (Plays.tv) solved the issue, at least in my case. Hope it helps.