[SOLVED] Just bad mistake in Ubuntu 18.04 when trying to run MyGame.jar

I try to run MyGame.jar with openjdk 8… and from command line but nothing going


/jdk1.8.0_172/bin$ java -jar MyGame.jar
Exception in thread “main” java.awt.AWTError: Assistive Technology not found: org.GNOME.Accessibility.AtkWrapper
at java.desktop/java.awt.Toolkit.newAWTError(Toolkit.java:472)
at java.desktop/java.awt.Toolkit.fallbackToLoadClassForAT(Toolkit.java:485)
… 18 more

I don’t know if it’s related but you completely miss the classpath (-cp) anyway.
Apart from that you don’t need to be in /usr/jdk1.8… for java to be available and thus it might not even find MyGame or is missing all the other files.

how I did it: oracle linux jdk1.8 to usr folder, libs and MyGame.jar copied to bin of jdk1.8 where java and javac is situated, then go there with cd /path/… command, then java -jar MyGame.jar but have mistake…
When I tried to install openjdk-8-jdk and openjdk-11-jdk and run it, rightclick MyGame.jar [V executbale ok] , then open with both openjdk by turns where MyGame.jar situated by default but nothing happens

move yourself and your game in your home folder

mv MyGame.jar ~
cd ~

try this

/usr/jdk1.8.0_172/bin/java -jar MyGame.jar

and see if it prints the same error

1 Like

thank a lot, it works…
but instead of openjdk-8(or 11) I use usual jdk.
question clear.