[Solved] Linux Installation Failed

This is the message I get when I try to install it:

Searching for JVM on the system…
Preparing bundled JVM …
./jmonkeyplatform-linux-x86.sh: 1: eval: /tmp/.nbi-2042403.tmp/jdk-linux-x86.bin: not found
Cannot extract bundled JVM

Could anyone help me? D:

@Darkchaos is the guy you’re looking for.

Thanks for the answer. :smiley:

Which version of the SDK are you trying to install?
Currently we have a few problems with timed out builds and uploads so it could be that for some reason the jdk is missing, but let’s hope it’s not the case.

Also could you please give us the output of ls -lsh /tmp/.nbi-2042403.tmp/?

The version I’m trying to install is v3.2.1 for 64bit Linux.

What exact version? 3.2.1-sdk1?

Sorry for the late answer.

That is strange, are you using this link: https://github.com/jMonkeyEngine/sdk/releases/download/v3.2.1-stable-sdk3/jmonkeyplatform-linux-x64.sh ?
I just tried it on my 17.04 KUbuntu and it opens the installer.
All I did was chmod u+x file.sh and ./file.sh

Can you maybe show the output as requested and maybe also issue the following command and compare the hash sum (maybe your download is broken):

$ md5sum jmonkeyplatform-linux-x64.sh
876fbbd374163e3a97c22b3477df05d4  jmonkeyplatform-linux-x64.sh

Nope. I’m using:

And yes, I already changed its permissions to allow the execution.
I guess I should try older versions.

Edited: I’ve just tried the link you posted, and it worked.
Thanks to everyone for your help.

In theory, your link should also work on a 64 bit system (at least in windows), but x86 is the 32 bit version anyway.

I could check if x86 is broken, but I guess it’s just that it would only work properly on 32bit systems.