[Solved] Mac OS: Installer not working

New user here! I recently downloaded jMonkeyEngine on a linux machine where it worked fine, and shortly after switched over to a Macbook running El Capitan. After downloading the installer, opening it would just result in a crash (the icon would bounce in the dock for a few seconds and then disappear). I tried all the older versions as well with the same outcome.

I decided to go poking around in the package contents of the .app file and found the bundle.jar file. I honestly didn’t think it would do anything, but I double clicked it, and the installer was up and running! I now have the SDK installed and it seems to be functioning properly so far, as far as I can tell!

I just wanted to post this here in case anyone else runs into this issue! If you happen to find yourself in this less than ideal situation, try the following:

  1. Right click the unzipped jMonkeyEngine SDK Installer
  2. Click “Show package contents”
  3. Navigate to “Resources/jMonkeyEngine SDK Installer”
  4. Double click the bundle.jar file

I hope someone finds this helpful!

3 Likes

Much appreciated - and welcome to our community :slight_smile:

2 Likes

Actually, we’ve had a few reports towards that as well (when opening the file via command line it showed an unnamed error).
I think this is a regression of a recent Mac OS X Version, seeing our SDK as untrusted (they added some trust mechansim where sideloaded apps are all shown as bad and unsecure).

I can only hope that this is solved with Netbeans 11 (an upgrade to our base), but we’ve seen crashes on Linux for that.

In other words: Thanks for finding out this workaround :slight_smile:

2 Likes

Glad I could help out, even if only a small bit! I look forward to being a part of this community, and hope I can manage to be of help again in the future!

3 Likes