[SOLVED] Model Loads Without UV

Preface: I’m just AWFUL at Blender. I’m positive that my problem is just a newbie mistake. Thanks.

So I made a (really bad) model in blender and set it up with UVs and textured it, but upon import to JMonkey, I lose all of my UV mapping and my texture is thrown everywhere on my model.
If anyone can help, here are the files I’m using.

Blender source file:

Wavefront OBJ (Should I even be using this; if not, what is better?):


when I load up that blender file, the model has no faces ?

Huh? Mine loads fine. I just downloaded blender today, maybe there’s a new file format structure for .blend. IDK.

hrmmm my bad, works fine now.

How are you importing your model, and how are applying the texture ? (ie show the code)

use either blends or ogre meshes ,obj has never worked for me. also make sure you load yo textures in the materials texture ,not only in the uv editor ,make sure u check export material wen exporting ogre

I don´t know if it helps but I had a problem with the UV as well:
You may want to try turning the texture upside down (not turning it through 180° but rather “mirror” it upside down, if you know what i mean)

I am sure I just messed up a simple setting that would´ve solved this when exporting the file, but mirroring the texture worked for me as well :slight_smile:
And, on a last note, I´m using a blender plugin to export in in ogre .xml-files.

I didn’t know you could import a .blend :stuck_out_tongue:

I imported it, and after playing around I just checked the “flip” checkbox in the JME material.

Thanks, everybody!