[SOLVED] Mouse is disabled in nifty

I have a strange experience with nifty gui. I always use a single nifty start/splash screen at the init of the app. It always works probably, even if I run the old projects. This time I started my project on base of a JME Tutorial. Because the main class also extends the SimpleApplication I added the nifty screen the same way as the times before, but this time there is no mouse support on the nifty screen. If I activate the JME settings dialog: in the dialog the mouse is supported, after i commit the dialog and the nifty page appears the mousecursor vanished. On desktop I can navigate by Tab and space keys and hit the startbutton, the mousesupport is back. The big problem is that when I use Android studio to run on AVD or build in APK for my smartphone, I cant click anything on the nifty page. Does anyone know why this is happening or what do I miss?

1 Like

I would recommend migrating to a different GUI library. Nifty is quite old and not maintained by its owner anymore. A good alternative is lemur: jMonkeyEngine-Contributions/Lemur: Lemur is a jMonkeyEngine-based UI toolkit. (github.com)

1 Like

And we’d have to see code to help you debug your code, otherwise.

@tlf30 Wow. this pictures looks awesome on my winter vacancy I will hava a closer look the “get started gui”!
@pspeed sorry again, that I have not appended some code snippets.

thank you

By the way, i have found out why my mouse was disabled while running nifty.
It was because of the flyCam. I disabled it after the nifty display. If I disabled it before then mouse support in nifty works fine.