[Solved] Networked Zay-Es question about setFilter()

Hopefully I am just staring at this too long and I missed something.

I have a networked EntityContainer with a FieldFilter. During it’s execution all is well. At some point, I want to change the filter via the setFilter call. I set a new FieldFilter, the container flushes out it’s entities properly, but does not replace them with the new entities that match the filter. I checked on the server side and there are definitely entities that match the filter. This worked a while ago and I did update zay-es since I tested this last. Has anything changed?

Which version are you running of Zay-es/zay-es-net exactly?


Then it may be related to this:

Zay-ES-Net v1.3.1

  • Fixed a bug introduced in PR #18 where the filter check in RemoteEntityData completeEntity() was inverted.

Just upgraded both libraries to 1.3.1 with same results.

EDIT: After looking into it further, I defined a callback on the GameSessionListener called sceneNumberChanged that was being called by a GameSession method on the server side and I forgot to set the callback on the GameSessionListener to @Asynchronous which locked up the server side. Totally my fault but at least I picked up the other bug fix on 1.3.1

1 Like