[SOLVED] No-Rig Animation problem

I have a scene setup in blender with several geometries, some are static, and some have none armature animations (No Rig Nor Bones) just key-framing transformation animations (Translation, Rotation, and Scaling), it works fine in blender and exported in glb, It works fine with windows 3D Viewer, but in Jme it produces the following error

java.lang.ArrayIndexOutOfBoundsException: Index -3 out of bounds for length 66
	at com.jme3.animation.CompactVector3Array.deserialize(CompactVector3Array.java:95)
	at com.jme3.animation.CompactVector3Array.deserialize(CompactVector3Array.java:42)
	at com.jme3.animation.CompactArray.get(CompactArray.java:142)
	at com.jme3.anim.interpolator.FrameInterpolator$TrackDataReader.getEntryClamp(FrameInterpolator.java:135)
	at com.jme3.anim.interpolator.AnimInterpolators$4.interpolate(AnimInterpolators.java:97)
	at com.jme3.anim.interpolator.AnimInterpolators$4.interpolate(AnimInterpolators.java:92)
	at com.jme3.anim.interpolator.FrameInterpolator.interpolate(FrameInterpolator.java:71)
	at com.jme3.anim.TransformTrack.getDataAtTime(TransformTrack.java:284)
	at com.jme3.anim.tween.action.ClipAction.interpolateTransformTrack(ClipAction.java:40)
	at com.jme3.anim.tween.action.ClipAction.doInterpolate(ClipAction.java:30)
	at com.jme3.anim.tween.action.BlendableAction.interpolate(BlendableAction.java:52)
	at com.jme3.anim.AnimLayer.update(AnimLayer.java:209)
	at com.jme3.anim.AnimComposer.controlUpdate(AnimComposer.java:390)
	at com.jme3.scene.control.AbstractControl.update(AbstractControl.java:118)
	at com.jme3.scene.Spatial.runControlUpdate(Spatial.java:743)
	at com.jme3.scene.Spatial.updateLogicalState(Spatial.java:890)
	at com.jme3.scene.Node.updateLogicalState(Node.java:239)
	at com.jme3.app.SimpleApplication.update(SimpleApplication.java:265)
	at com.jme3.system.lwjgl.LwjglWindow.runLoop(LwjglWindow.java:580)
	at com.jme3.system.lwjgl.LwjglWindow.run(LwjglWindow.java:669)
	at java.base/java.lang.Thread.run(Thread.java:829)

If you have hints or tricks to make animations suitable for jme, I’ll be thankful

Below are all the resources I review when creating animations. From key frames to armature animations.

Animations in Blender 2.61 and JME3

jMonkeyEngine 3 Tutorial (7) - Hello Animation

Creating assets in Blender3D

Moreover below are the blender versions I use:
Blender 3.4 I use it as primary.
Blender 2.79b I use it as backup.

See below if you want to look at my animations working. :slightly_smiling_face: Both animations created in Blender 2.79b and 3.4 are in the videos.

If you encounter any specific issues after reviewing everything feel free to reply.

1 Like

Thank you for your response
My problem is different
Check this out video

What I want is similar

My animations are similar to this(without rig, without bones, without skeleton, and without armature)

Have you tried gltf? I believe JME supports gltf better than glb in general.

From a “what does it support?” perspective, gltf and glb are interchangeable as far as JME is concerned. There are differences in loading/memory performance but as far as features, they support the same thing. (One is delegating to the other, actually.)

1 Like

Solve it
I needed to Bake Action in Blender

1 Like

@carpenter Can you provide the details of the steps so others can use the solution? And maybe a screenshot?

After all the animations you wanted are ready

Select Object → Animations → Bake Action

Then Check Box these Selections

And This is the Result

1 Like