[SOLVED]Problem building applet with JME3

Building Applet with jme3 gives an empty dist folder

I’m following this tutorial: https://wiki.jmonkeyengine.org/legacy/doku.php/jme3:jmonkeyplatform:application_deployment

I get a BUILD SUCCESSFULL but the DIST folder is empty, I can do it if I remove the option " Enable Web Start." (I get my JAR in my BUILD folder)

My application is only a simple hello world to try JME3 with applets


Thanks a lot for this,

I have an other problem when trying to run the applet,

I get the error : java.lang.UnsatisfiedLinkError: no lwjgl in java.library.path

I’ve followed thoses 2 links



but still can’t find how to set the VM Options in JME3, thoses 2 tutorials were for JME2 and the folders they say to point for the natives does not seem to exist in JME3

I tried theses paths :

-Djava.library.path=“C:Program Filesjmonkeyplatformjmonkeyplatformlibs”

-Djava.library.path=“C:Documents and SettingsBureau1DesktopFolderJMONKEY ProjectsBasicGame2distlib”

none of them worked

they path I saw on the forum is : -Djava.library.path=${JME-dir}/lib/lwjgl/native/${operating-system}/

but in JME3 there is no LIB folder, and with a search in the complete JME3 folder there is no “windows” folder too

Could someone please point me out what the VM Options path is using windows with JME3 ?


There should be no VM options, something else is wrong

I still get the error:

Exception in thread “LWJGL Renderer Thread” java.lang.UnsatisfiedLinkError: no lwjgl in java.library.path

at java.lang.ClassLoader.loadLibrary(Unknown Source)

at java.lang.Runtime.loadLibrary0(Unknown Source)

at java.lang.System.loadLibrary(Unknown Source)

at org.lwjgl.Sys$1.run(Sys.java:72)

at java.security.AccessController.doPrivileged(Native Method)

at org.lwjgl.Sys.doLoadLibrary(Sys.java:65)

at org.lwjgl.Sys.loadLibrary(Sys.java:81)

at org.lwjgl.Sys.(Sys.java:98)

at com.jme3.system.lwjgl.LwjglAbstractDisplay.run(LwjglAbstractDisplay.java:183)

at java.lang.Thread.run(Unknown Source)

when running the applet (everythings builds OK)

I did include all the .JAR located in the folder:

C:Program Filesjmonkeyplatformjmonkeyplatformlibs

Here is a screenshot of my WebStart options:

How can I get the lwjgl to link correctly?

The natives won’t work in webstart. You have to include the extension for LWJGL: http://lwjgl.org/jnlp/extension.php

I guess the option for that is at “Extension Resources…” button

Thanks a lot ! Worked like a charm :slight_smile:

How could I include the extension for LWJGL.

I clicked on the "Extension resources: button and got some window with 3 fields (Href, Name, Version)

Should I put the above mentioned link in the href field?(I did that but it didn’t work)…